BSA History report does not reflect %complete accurately

I recently updated a Scouts Second Class rank requirements to 97%. He is ready for his Board of Review. I did check the approve box when updating his data and then saved with date completed. However when I run the BSA History report the recently added requirements I’ve checked off do not reflect in the report. I have tried logging out and back in as well. Does this require a specific time period to elapse before the report is accurate, am I potentially missing a step, or is there an issue with IA?

Can you clarify where you entered the rank requirements and where you pulled the report?

Thank you for helping Jacob. I entered rank requirements in Scoutbook, My Dashboard, My Unit, Troop Roster, click on Scout, Advancement. The report shows the same data in Scoutbook and Internet Advancement however it is not complete.

Does the report and the Advancements show the same version?

Not sure I understand your question. How would I check versions?

@TroyBugni - the version of the rank is near the top of the rank page.