Cannot record electives - endless loop back to login

  1. I can record requirements only by using quick entry - checking a box for an individual scout on their advancement page takes me back to the dashboard.
  2. Quick entry only has options to record requirements, not electives. I tried different browsers, no luck.
  3. Clicking most menu options pulls up a page to log in to the mobile app (I’m on a computer, not a phone) and both the ID and password fields are grayed out, read only.

I reset your admin positions, see if Scoutbook works better for you now.

That fixed almost everything! I was able to enter advancements. I was able to enter the shooting sports patch for a tiger and an AOL, but when I tried the next webelos scout it won’t show that as a choice in the award list. I tried quick entry, but then it says I don’t have permissions to update awards for any scouts. It says full control on the scout’s individual record.

@JaneMarpes Is that for a scout who has earned the Webelos rank yet? (I know that’s not a requirement, but we’ve seen issues with that before)

Yes, it is. I also realized after reading some other posts that I might not always be in scoutbook. When you reset my rights, I think it fixed IA. Some links direct me to IA with the red graphics, and others take me to scoutbook. I had to use IA to enter most things because Scoutbook keeps giving an error in quick entry (see screenshot). If I try to record advancements in Scoutbook, I click the scout in roster |tan advancements button | Webelos | Cast Iron Chef checkbox and then it takes me to My Dashboard.

Problem 1: can’t select any scouts

Problem 2
Clicking a checkbox here

kicks me right back to here

In Scoutbook, are your Scouts assigned to dens?