Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Committee Chair can't edit ASM Connections

Hello, I’m the Committee Chair for my Troop, I have admin rights for the Troop under scoutbook. I used to be able to connect ASMs to scouts through the “Connections Manager”. I can no longer do that. Can anyone explain why? I need ASMs to have edit rights to the scout accounts so they can sign off rank requirements.

Thank you.

@MickeySnider most likely one of 2 things

  1. your admin is messed up and needs a refresh - Go to unit Roster > Click your name > click Admin > click Update - that might solve it

  2. The person who you think is an ASM - the BSA# in Scoutbook might not be registered as a leader - if you post it we can see

Thanks, I’ll try refreshing. He has edit rights for all but 2 or 3 of the scouts for some reason. And it’s not just him, I can’t change anyone’s edit rights. Let me see if this works.

No, didn’t work. I can give anyone “View Advancement” or “View Profile”, but the 3 “edit” control options are all grayed out. And that goes for everyone, I can’t even give myself permissions and I can’t even click on anyone if they are also Admin.

it sounds like none are registered - post a few BSA #s

They are all 100% registered and have been for many, many years. I was able to do this with no issues less than a month ago, now I cannot. This is an issue with scoutbook, it is not an issue with my leaders. Is there someone who can actually look into this with Scoutbook and get me an answer?

Donovan or I can look into it. That’s why he asked you for some bsa member numbers.

Mine is 110062416
ASMs is 133622368

Thanks.

I’m not sure if I’m following the full explanation. Is it two or three scouta specifically that you can’t change the connection on? Or is it that you can’t change anyone’s connection?

I can’t give any of my leaders edit access to any of the scouts. I can give them viewing access, but not editing access to update their advancements.

@MickeySnider 133622368 has Full Control to all scouts BUT - MF

@MickeySnider perhaps a screenshare might be able to isolate the issue

I need to turn that into a green dot. Which is done by clicking “Full Control”. The only options are for him to view.

@MickeySnider lets try this a different way - go to the scouts page > connections > find the adult (if listed) > and change there - connection manager can be troublesome if you have not cleaned up old connections or have a large unit

That sends out a “connection invite”. It doesn’t actually establish the connection.

Like I said, this was working problem free when I was in there a month or so ago.

I can confirm that I am seeing the same issues in my unit. Connection Manager only offers View Advancement or View Profile options for all adults that I checked. I have verified the ones that I checked are on our my.scouting roster in their registered roles with matching BSA IDs.

I replicated the issue in Firefox and Chrome, both in regular windows and in incognito/private browsing windows, with and without any extensions (including Feature Assistant) running.

I confirmed that I can set other permission toggles when inviting an unconnected registered leader to connect from Scout’s Connections → Add. This works on all browser/window type connections I tried (with and without the Feature Assistant running).

ETA: I also tried toggling my Unit Admin role to make sure that hadn’t glitched behind the scenes. No change in behavior.

Pretty sure I know how this system works - we are just trying to help.

It doesn’t actually send an invite if you are a unit admin (should say that in the fine print).

OK - I see issue and have it reported - BUT doing as I advised will work