Den Needs Approval Report doesn't show list of items

Hi, I am a Den Leader, and when I select the “Needs Approval Report”, the report page loads, and if there are items needing approval I can see a number, but there’s no list below (and clicking doesn’t expand anything):

Whereas, when there’s nothing to approve, I at least get the line saying so:

I have tried this in both Chrome and Edge, same result.

Both my wife & I have the same problem! She is a den leader and there are 13 items that need approval but none of them are showing (see image)! I’m advancement chair and I can only see 16 of the 53 items that need approval. I can’t speak to the 37 items I can’t see but all 16 items I can see are new scouts who signed up this fall.

I’ve been using Scoutbook for several years (even before it was free) and I’ve been advancement chair for 3 without seeing this issue before. This is definitely a bug that Scoutbook needs to fix!
Wife’s “Needs Approval”

My “Needs Approval”

I am seeing the same thing on both the Pack and Troop that I admin and am Advancement Chair for. 55 showing for the pack on summary but only 12 showing up on the actual itemized list. 14 on the summary for the troop but only 1 on the itemized list.

I might be running into a similar issue as well. I noticed this morning that some of the completed items are not showing on either the pack or den approval reports for me. I am the advancement chair for our pack.

I have the same issue, and it’s been there for at least a few weeks … The “Needs Approval Report” shows the “Total: X” count, but nothing listed.
The “Approve All” button appears to work, to blindly approve items.

We have yet to be able to reproduce this - it SOUNDS like a connections issue - if you are experiencing this - go to unit > roster > click YOUR name > click your admin > click Update - see if that resolved it

go to unit > roster > click YOUR name > click your admin > click Update - see if that resolved it

I’m not sure I understand this direction, sorry - if I go to the Pack roster, I can’t click on my own name. If I go to the Den roster and click on my name, I get a never-ending “Loading” spinner and no transition to a new page.

If I go to the Connections Manager, even updating each Scout individually to ensure everything was set to “Full Control”, I can only see advancements from the two new Scouts who joined this year. I can’t see the ones in the report from Cubs who joined in prior years.

If this is something one of our Pack (Scoutbook) Admins needs to handle instead, please let me know.


A unit admin (2 keys on the unit roster) needs to go through the process Donovan described to reset your den admin role.

Thanks Donovan for the quick reply … I followed those steps, but does not appear to have an effect.
The odd part is that I still have full access (so not a fully disconnected connection/permissions) – it shows the pending count, and allows for approval (which does go through)… it’s just the list display for review that has the issue.

I believe this has been happening since October (but don’t recall the week/day), if that helps correlate against any release/change history.

No errors in the browser dev tools js console log or network tab.

Happy to help in any further testing/debugging/screenshots – fellow web app/db developer here! I fully understand the difficulty in trying to resolve something you can’t reproduce, even when sure it’s there.

I just ran a test with one of the dens in my pack. I entered an item in a webelos adventure and sure enough it is in the den needs approval and the pack needs approval. To further clarify, I am a unit Admin, Key 3 (Committee Chair) so it seems to be working for me.

@DavidWestbrook are you a den admin or a pack admin? If you have any idea which items were included in the counts but not listed, the scout’s bsa member number (no names) and the items not listed could help us.

@jacobfetzer David is a pack admin.

No problem! Here are various related ID’s:

All 4 scouts in that Den (e.g. ScoutUserID=9690469)
Webelos Rank Req #1 (3mos in Pack).

I agree on timing. I did note in the forums other issues noted (with fixes implemented) on the Needs Approval Report around that time as well - as a software tester by profession, I always worry that one bug fix broke something else :wink:

@edavignon Thanks, I will point our Pack admins to this thread as well.

@Stephen_Hornak Did you manually mark completed or use Quick Entry? I’m still trying to figure out why not all of my scouts show up under needs approval, maybe there is a difference between manually selecting completed requirements vs using Quick Entry? Can you try the other way to see if you get different results?

@BruceMacomber - I had used quick entry and just marked the req as completed but not approved. I have backed it out and will try scout by scout.


The developers are trying to collect information to help find the source of this problem. Can you post the Scoutbook User ID (located under Edit Profile) for the Scouts and the items that are not appearing in your Needs Approval report?

I am still having this same issue as well. But I have no idea which scouts have pending approvals. I just see that there are 14 listed but only 1 comes up in the detail list. I tried the “update” on my admin per @DonovanMcNeil suggestion and same thing.

This is happening for both units I admin.

The developers are aware of the issue. The workaround is to use the Pack’s needs approval report.

I have the same issue with both the Pack’s Needs Approval Report and the Den’s Needs Approval Report.