Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

"failed to load classes" error in completed training table

I’m trying to print out certificates for classes I have just completed, but when I go to the “Completions” section it pops up an error dialog saying “failed to load classes” and if I try to use the “member training report” link it comes back with “Authorization failed (-2)”. When I go to the training cards for those classes it has the correct completion date but there doesn’t appear to be a way to print certificates from there.

Is there something else I need to do so that I can get authorization to see my own training history?

Thanks.

Bill, I just tried mine and it worked okay for me. Did you try the usual stuff, clearing your cache, etc.?

Thanks for the suggestion. Others in my troop can see their stuff too, so I don’t think it’s a system thing, but different browsers, cache clearing, going incognito, and trying over multiple days hasn’t worked for me.

I’m having the same issue. Just wondering if you got yours to work?

I’m having the same issue today. Anybody have any ideas?

Are you able to look up your training history when you use the Betty chat bot on the log in page at my.scouting?

No… This is what I get:

We were unable to find the training history at this moment. Please, try again later. - Cannot read property ‘data’ of undefined

I get the same error from Betty

Sorry, friends, I can’t figure out the answer. I assume everyone is clicking “My Training” from the menu, then clicking “Completions.” I just tried it again and it works for me. One question…are you using Chrome for your browser?

They tracked it down to my email address having two member IDs associated with it, one having a misspelled last name. The training apparently went in OK but it got confused on the way back out.

Thanks for the help.