Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

International Spirit Award showing 17% progress

My son’s International Spirit Award is showing 17% progress without any requirements being done.

I wonder if it’s doing some sort of unmarked auto-credit (i.e. not displayed in the UI) for Citizenship in the World or World Conservation Award. Has he earned either of those?

Those are the only things I can think of that could theoretically cause “auto-credit” for work that’s not marked complete in the award itself. My son completed the MB requirement (which is marked Leader Approved), and he’s showing 20% complete.

It’s odd to me that the 17% you’re seeing doesn’t match either a uniform assignment of value (i.e. 1-4 + 5.1, 5.2, 5.3 = 7 requirements, 100% / 7 reqs = 14.2% each) or uniform for the “numbered” requirements (100% / 5 reqs = 20% each). It is, however, the average of the two “credit” distributions, i.e. (14% + 20%) / 2 = 17%.

Do the % change if you open up the award requirements page?

It is the same percentage in both views, it doesn’t change.

Also, I tried to reply to this thread using Chrome and the option was not there. I had to use Firefox.

That’s odd. I’m using Chrome right now and I had no trouble replying. Are you seeing the same odd behavior for the award in Firefox?

Might be a browser problem. Sometimes, closing the browser and clearing the cache can help.

Usually that means you are not logged in (even if they theoretically should be)

This is what the award screen looks like in both Firefox and Chrome.


I cleared the cache in Chrome and it still won’t let me reply. If I refresh the page, it will show the reply button briefly and then disappear.

Solved: The Adobe Acrobat extension was altering the webpage for some reason. Once I turned it off, it worked.

1 Like

What happens if you go into one requirement and save it without adding a completion date?

That worked! I opened the first requirement in the award and saved it without adding a date and it went to 0%. Thank you.

P.S. He was the only Scout I could find with this issue.

I’m glad it solved that for you. Doesn’t really explain how it got set incorrectly in the first place in order to fix a potential bug. It’s something for us to watch for going forward if we see more of this. Thanks for reporting it.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.