Parent/Leader/COR can't Login or Accept Invite

In the Troop I admin, our COR is having issues with accepting the Scoutbook invite. He has had this issue for, what feels like, several years and across three different units. First in Pack 13, then in Troop 15, and now in Troop 12. He was a registered leader in all three units. I don’t know if this is an issue with multiple accounts or BSAID numbers or userID numbers associated with the same email address. He has tried multiple times to accept the invite and login but unsuccessful.

BSA ID: 124417216 UserID: 1412123

Can someone look at his account and see if you could give us some help/guidance on how to correct this?


he needs to use his user name to log in

I believe he has tried that. He keeps getting the “working” pinwheel and it never stops.

have him log into first

10-4. We will try that next, then once successful there, have him attempt login to SB using same credentials.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.