Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Scout doesn't see group activity to join

I’m an admin for our troop, and I created a group activity for our summer camp. I told my scout to go join the group activity, but it’s not visible to her. Am I missing something obvious?? (I’m only an admin for 1 unit so I know it’s in the right unit.)

TIA!!


Screen Shot 2021-07-14 at 4.04.52 PM

When you say join, are you talking about the scout using the Scouting app, or via Scoutbook?

It doesn’t work t his way. One records campouts, but one does not join them.

I thought that you could do that using the Scouting app (not from Scoutbook). It used to say so in the documentation. Maybe that never worked properly? I never tried it, and, to my knowledge at least, neither did my son.

ETA: Apparently, it is supposed to work from IA2: As A Parent Or Youth, How Do I Record A New Activity (IA) | Scoutbook Knowledge Base

1 Like

Just tested - I had to jump back a month to get it to load - but it failed when trying to join as a Scout - reported

2 Likes

Good to know, @DonovanMcNeil. I’m still curious as to whether or not its supposed to work from the app (@AprilMcMillan?) and what path the OP’s scout was using that was breaking.

The scout is logged into Internet Advancement (linked from Scoutbook) in Google Chrome. It has worked in the passed. I even made a video to show Scouts how to do it :slight_smile: How to join an activity-campout.mov - Google Drive.

1 Like

Great (well, not great actually…). Looks like @DonovanMcNeil has the right bug reported, then. And now we wait for development to find and squish it… :clock10: :clock1030: :clock11: :wink:

ETA: I realized my keyboard mumbling didn’t make any sense. “Great” that there’s a now-public howto video and that the right bug is being hunted. “Not great” that the bug exists…

1 Like

When you see errors happen if you have a little nerd in you - you can turn on Inspect (or developer mode) > go to Network and clear it > then run action again

Here you see in this instance API registeredParticipants Failed - this is HUGE data to speed up a fix

Screen Shot 2021-07-14 at 5.31.09 PM

Hunh. So, at the risk of revealing how little nerd cred I have in this field, I assume the only indication that there’s an error is that it’s red, or does it actually say error somewhere beyond the boundary of the screen capture?

depends on browser - in this image red is big clue - but also see the process ran for 1.7 seconds which is often a clue too

Cool. Thanks, @DonovanMcNeil. I learned something new. Now I can go home. :wink: