BOY SCOUTS OF AMERICA

Scouting Forums

Complete Angler Award missing in Troop Recognition Report

I’m the advancements chair for my sons’ troop.

September will be my first Court of Honor using Scoutbook for troop management. I’ve been testing different features and reports ahead of then in order to familiarize myself with the system.

When I ran a Scouts BSA Troop Recognition Report just now the report appears to include all ranks, MBs and special awards earned since the last COH …except it does not include Complete Angler Award for the two Scouts who earned this award in July.

I double-checked that the beginning and end dates I entered was inclusive of when they earned Complete Angler. The dates were accurate.

I also double-checked that Complete Angler is properly recorded with the correct date in their Scout records. It is, in fact the little Complete Angler icon shows up in their individual profile.

Other awards such as Den Chief Service or Fireman Chit are showing up in the Recognition Report for other Scouts.

Is this a bug or is Complete Angler intentionally omitted from the Recognition Report for some reason?

Thanks in advance,

  • Rob, Advancements, Troop 37B, Arlington Heights, IL

Hi Rob,

The developer is looking at this now.

I do notice, however, that the award is not listed here:
https://www.scouting.org/awards/awards-central/

But it is on this page that links to the other page:
https://www.scouting.org/outdoor-programs/awards/

I’m not sure if that means anything, but I would think it needs to be in the database as an award to be in the right place for the report to find it. The Scoutbook page and the report might be checking different things.

We’re looking in any case.

Thanks,
JW

One more thing:

Can you please check whether it has been marked awarded in Scoutbook? If it is and you don’t check “Include Awarded Within Date Range” then it won’t be listed.

Thanks,
JW

Thanks. Complete Angler is listed in the Scoutbook awards dropdown as an option next Cyber Chip, Den Chief Service, 50 Miler, etc

All the other awards that Scouts earned are showing up on the Recognition Report. Only Complete Angler is missing.

Good question. It is not marked as Awarded.

It is marked as Complete and Recorded by a Leader (me).

Rob, on the Scout’s Awards pages, what color do you see next to Complete Angler?

Rob, by any chance do those Scouts have a membership with another unit in Scoutbook?

Now…is it marked approved which is what Jennifer was alluding to.

No other unit affiliations.

Hi Jennifer-

Perhaps this is the root of the issue. It is marked Green (complete) and when I attempt to make it Approved/Recorded (as I thought I originally did) the system will not accept it and the item remains green…

That explains why it’s not showing up in the Recognition Report but raises a new issue in that the Complete Angler Award is not able to be marked as Approved/Recorded. :slight_smile:

PS: the Complete Angler Award has 4 requirements: 3 fishing-related MBs + another activity. All of the Scouts in our Troop that earned the award had previously completed 1 or 2 of the required MBs last year and then completed the rest of the requirements at summer camp this past July.

The newly completed MBs have not yet been awarded so Scoutbook is showing Gold (Awarded) on 1 or 2 of the MBs but then Blue (Approved/Recorded) for the other requirements.

Could it be that because some of the underlying requirements have not been awarded that the overall Complete Angler Award cannot be marked Approved/Recorded?

Rob, try looking at the Scout’s Membership page.

They are only registered in one unit - our troop.

Are you a Troop Admin? If so, then try this:

  1. Go to your Troop Roster page.
  2. Click on your name.
  3. Click on your Troop Admin position.
  4. Click Update.

This should reset your Admin connection to all Scouts in the troop.

Hi Jennifer - Yes I am in an admin position and am connected to all Scouts.

That’s me marking the underlying requirements as Leader Approved in the screen capture. Thanks.

Yes, I’m asking you to reset your Troop Admin role using the instructions above. Sometimes the connections get messed up.

Thanks. Yes. I reset last Sunday and again tonight. Still same issue. :slight_smile:

Do you think it might be because some of the underlying Award requirements are Completed/ Approved/ Recorded but not yet Awarded?

Thanks for your help and suggestions!

No, the underlying requirements should not matter.

Usually, it’s a permission issue between the adult leader and the Scout. Or it’s some kind of Scout Membership issue. Please go to the Scout’s Membership page, click on the Scout’s current membership with your troop, make sure the box is checked next to “Position Approved”, and then Update.

Hi Jennifer - yes, both Scouts are checked Position Approved and I did Update both just now.

Still happening.

Rob,

Can you please check again to confirm you still get the same results. Thanks for your help with this.

JW

Yes. Still happening.

We also now have a 3rd scout who has earned Complete Angler so I started “from scratch” with him.

Same issue.

Despite being an approved leader etc I am unable to mark Complete Angler as recorded/approved.

This means it does not show up in either needs purchasing or needs awarding troop reports.

Thanks for looking into this!!

FYI- I’m not too concerned about it as I know I need to buy the awards and I will mark them as awarded after our COH in a few weeks (provided the system allows me to mark them awarded).