Need Help in IA: When I click "Advancement" it disappears

When I go into Internet Advancement (IA), check a scout to add a belt loop completion, and then got to Record Progress and then click “Advancement”. It immediately disappears and shows an error at the top to clear the cashe or contact Council. I have cleared the cashe, refreshed and it still happens. Council does not know what to do and said to go to this forum for help. I am one of the Key 3, the Cubmaster, and IA says I have access/control to everything, but the “Advancements” disappears so have not way to enter a belt loop completion for a scout when needed. Please help!

@JamesKnauff try in a Private/Incognito window - kind of sounds like you have a pop up blocker on

Thank you, but I tried Incognito weeks ago, and still does not solve this problem. Have also tried 3 different computers. I can bring up “Awards” and “Rank” but not “Advancement”.


Is it independent of which scout you’re entering data for, or is it only impacting a particular subset of scouts?

What path are you taking to log into Internet Advancement? Are you going through my.scouting (clicking on Menu ->BSA Web Links → Internet Advancement 2.0)?

Which browser are you using?

Thank you. My Council just tried merging two accounts I had showing, and it is now working. Hopefully, will be a permanent fix. If not, will reengage on this issue.


1 Like