Not able to "multiple" register my Scouts

I have three Scouts that I’m working to register with a local Venture Crew (same council but different district). My daughter (14847637) appears in the “My Applications” tab of my account and I was able to complete her application online. My sons (14538523 & 14538576) do not appear in the “My Applications” tab, so I tried to register them with the Crew via Because they’re currently registered with a Troop, the system forces me to log into but then gives me an error stating something akin to “you don’t have permission to do this transaction.” I’ve tried logging in under my own BSA ID (14671462) and theirs, but the result is the same. We’ve also logged into my wife’s account (132131359) but they don’t appear there either. We’re all linked correctly in Scoutbook, so it’s a bit perplexing. Is there a way to link my sons to my account? And, is there a reason I’m unable to multiple them to the Crew? Thank you!

@JohnCooper2 - please talk to your council

I recommend that you contact your local council and ask them to use the Registrar Tools to look up your children. When they look up your children, they want to check your children’s “User Relationship” and make sure that your children are connected to you as parent with Only your correct BSA member ID number

I’ll give the registrar a call today and see what we can do. Thank you again.