Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Purchasing reports not opening in mobile

When I go to my Needs Purchasing Report, I can’t open my currently open Purchasing Report. It just opens back to that tab. I’ve tried in multiple browsers. I’ve tried with and without desktop site checked.

Any chance it’s not just me?

It is working for me.

Try logging out of Scoutbook, then logging back in again. You might also need to clear your cache and cookies.

Again, multiple browsers. Not a cache issue. Not a sign in issue. Just tried it in an incognito browser, too. I’ve tried it in a vnc session into a Linux server I run. Nothing is working. I’m tech support, so it’s not like I haven’t tried everything I can think of from my phones.

I’ll use one of my kids laptops tonight and see if that works.

Are you in more than one unit, or do you have kids in more than one unit?

@jacobfetzer - no. I’m in 1 unit, as the cubmaster. my boys are both in my cub scout pack.

@JenniferOlinger - I’ve now tried a laptop and I still can’t view the open purchasing report. I’ve even spun up a completely stock Windows 10 virtual machine and I still can’t view the purchasing report. I click on “View Open Purchasing Report” then it takes me right back without downloading anything.
Here’s a screen recording to show what’s going on: https://photos.app.goo.gl/FCF4kj4Nar6rR82R8

Are you able to add another item to the PO?

@jacobfetzer - I was able to add another item to the PO. It increased the count to 93 items, from 92. However, it still does the same thing. I click on the button to view open PO #, and it just takes me to the same page. I’ve even granted myself unit advancement chair, even though as pack admin, I already can do everything they do. I’m running out of ideas. It’s not cached. It’s not a matter of just logging out. It’s not any one device. I’ve tried it on an android phone, an iPad, a macbook, a Windows 10 virtual machine on my macbook, a linux virtual machine on my phone. I can’t figure out why I can’t view the report. It’s not blocked content, as I’ve made sure that pop up blockers are all disabled, my tracking cookie sniffer (Ghostery) is off.

@jacobfetzer - I’ve even gone so far as to use a UA spoofer and set it to use IE10 as my user agent. That photos.goo.gl link I shared before is what happens on all my devices, on all browsers.

@Mattgyver - I have opened my pack purchasing report on my android phone and in firefox on my win10 pc without issue. I will test the other 5 browsers I have on my pc i a few.

So on Chrome, Edge, Opera and Sea Monkey the PO that I have opens without issue.

@Mattgyver Try resetting your Pack Admin role:

  1. Go to your Pack Roster page.
  2. Click on your name.
  3. Click on your Pack Admin role.
  4. Click Update.

Then log out, and log back in again.

If that doesn’t help, we might need to get the PO url from you.

@Stephen_Hornak - I’m not doubting you. I’m just saying that it’s not working for me. Yet I can approve awards, grant pack admin to any adult leaders in my unit, and make scouts inactive. If you watch that video I linked, it happens on every device, in every browser. I tap/click on view Open PO, and it just loads the same page.

@JenniferOlinger - I’ve updated my pack admin role and logged out and in again. Still the same thing.

Here’s my URL: https://www.scoutbook.com/mobile/dashboard/reports/purchaseorder.asp?POID=467810&UnitID=84358

It does the same thing with the closed POs.

Is it something funky with our unit’s setup in Scoutbook? My wife’s account was still pending and she’s never received an email to sign in to her account… I’ll try changing her email at some point so I can test that.

I am not sure.

I have seen this before, but usually the user is connected to another unit but not an Admin in the other unit. I don’t think you are connected to another unit, though, so it must be something else.

I haven’t been with another unit since 2003 when I was a scout. Unless someone with our troop here had linked me on their side, but it doesn’t show up in my membership or leadership anywhere.

Adding something to the open PO should also open the PO. Does that send it back to the dashboard, too?

If you go to the needs awarding report, you can see what’s in the PO. Does it list 93 items also?

It took me right to the dashboard again when I added the award. Yes, I can go to the Needs Awarding report and see what hasn’t been awarded yet. Interestingly enough, there are 92 items in the needs Awarding.

Any idea what’s missing from needs awarding? Maybe a special award or a scout who isn’t on your unit anymore? That might be a clue to reproducing this.

I’ve also sent you a DM to collect some info. Look for a notification on your avatar in the upper right.

I can’t tell what isn’t in that list as a lot were from in March, before everything shut down.

what’s odd is that somehow, and only once last night, I was able to view the purchasing report. It was via my phone. It was around 10:50pm eastern time. I quick exported the report so I can look at it tonight and verify against the needs awarding report. I tried this morning, and again can’t view the purchasing report. I don’t know how I got in last night since I didn’t change anything on my end. I am now on my work laptop, and it isn’t letting me in. I’m definitely wondering if it is something with my account or my unit.