You must first activate your own mobile number before sending text messages to others

I couldn’t find the Edit Profile at first and this wasn’t showing in search, so I start documenting this just to share, but then I ran into an issue (at bottom).

You must first activate your own mobile number before sending text messages to others. You can do this from your Edit Profile page.

image

https://scoutbook.scouting.org/mobile/dashboard/

Dashboard > My Account > Edit Profile

https://advancements.scouting.org/profile

Then check the box for: I would like to receive text messages from the Boy Scouts of America.

I also changed my country to USA, not sure if that’s required. It didn’t seem to like taking both settings at once, so it took a few savings for it to take.

I ended up here…

image

BUT, even after doing that, I’m still getting the same message when I try to send…

image

What am I missing? Does it take a few minutes to propagate first?

I thought maybe it was because it was Home and not Mobile…

…but that doesn’t seem to solve it either…

image

When you go to send messages, do you see the little cell phone icon next to your name?
image