Application Manager - multiple errors


I transferred in six Arrow of Light scouts to my troop over the weekend. The scouts are now showing up in the Application Manager; however, whenever myself (SM) or my Committee Chair attempt to approve their applications, we recieved the following error: “Assigment failed. Position limit has been reached.”

I then cleared my cache in Google Chrome and am now recieving this error: “Missing JWT Token.”

I tried again with another scout but started receiving the “Assigment failed. Position limit has been reached” error again.

See below for the system information.

(If you are reporting an issue with My.Scouting, please include all of the following items so we can better assist you:
1) Hardware: Desktop or Mobile (if mobile, please be specific) – Desktop
2) Operating system – Windows 11
3) Browser – Google Chrome
4) Browser cache has been cleared or you are using a private browsing mode (aka Incognito Window in Chrome) – Yes

Thank you!)

@RonaldBlaisdell ? I have never heard of this error

@GregoryKosharek can you give a BSA # of one or 2 of the scouts? No Names

I am having the exact same issue.

Here are three of them.


@GregoryKosharek looks to me like they are good? Look at roster - not SB

@GregoryKosharek - the JWT error is a mismatch between public and private keys. That was initiated by clearing the will self heal on a ckean restart of the browser session.

Yes they are on my roster (both in my.scouting and Scoutbook) but they are also showing in the application manager as pending acceptance and we’re getting email notices to approve them which we are unable to do. Is this normal? If not, how do we resolve it?

@GregoryKosharek - are you unable to check the boxes then cluck on the yellow pending.

This is what I get when I go in to accept.

When I click accept, I get this:

When I click the checkbox, the only added option I get is “Draft Email” which bring up an email with “null” in the to: address bar.


@GregoryKosharek - wait a minute… this looks like new scout applicants rather than in council transfer. I have done in council transfers and they never resemble that.

Ok, forgive me. I was just appointed SM last week and I’m still figuring this all out. I went into Roster > Transfer In…from here I entered the scout’s information which transferred them to my troop roster. The same scouts are now showing up in the application manager pending acceptance. Did I mess up somewhere?

Transfers initiated by the pack or the parents go through the same approval process as new scouts.

If that’s the case, I should be able to accept them, correct? But I’m not able to do so due to the errors…or am I missing something obvious - which is possible?

Try logging out completely, closing all your browsers, maybe even clearing cache, and try again.

Cleared my cache again, shut down browsers, restarted computer, and still receiving the same error.

Try waiting overnight. The automated overnight process might resolve things.

Will do; however, this started happening earlier in the week so I’m not holding out hope that another night will fix it. Fingers-crossed though.

@jacobfetzer - ah gotcha. I think i pulled the scouts from the troop side or just never noticed that approal portion.

Yeah, if you pull them on from the troop side, if bypasses the approval process.