Approve all in "needs approval report" is not working

I get an error when reviewing the “needs approval report” and trying to mark off all as complete, both on the pack and den level. It works if I go into individual scouts, but that defeats the purpose.

(sorry if this is a duplicate request. I looked quick and didn’t see anything)

I am using chrome, and have tried on multiple apps and my phone)


@MichaelCasella Go to unit Roster in Scoutbook > Click your name > click Admin > click Update - that MIGHT solve it

Thanks - I just tried what you said, but it did not :frowning:

my guess is there is a scout on the report you are not connected to - we cannot see report status or live view

I confirmed I’m connected to the scouts in question. It is also just the “approve all” button that causes the error, and not individually approving scouts

@MichaelCasella It only works if you go in through your unit roster page and click your name. It does not work to go through your positions under my dashboard.

I did it through the unit roster page :man_shrugging:

Here’s another weird thing. It looks like after that update, when I click “approve all”, one random scout gets approved on the list, and then the error comes up. I can go through multiple times and clear out the “needs approval list”

It does point to there being one item that select all is trying to approve which you do t have permissions to. After you approve everything the slow way, what does your needs approval report look like?


I can go through and approve everyone one by one. The last scout works but I still get the error afterwards.
This has been tried for approvals for my den, where I am a Den admin, for individual adventure requirements, and approvals for other dens, of which I am a pack admin, but for award requirements

@MichaelCasella it almost sounds like there is something from another program on the list and you might not see it - I can setup a screenshare to take a look

Do you still have the approve all button after you approve everything? If so, what happens if you click it?

Check the Scouts in the report to see if one still has an extra Pack membership in their Memberships

1 Like

@GaryFeutz No scouts with extra pack memberships. I just did a test with my own son and using the “approve all” button to approve a requirement. Still gives the error

@jacobfetzer I do NOT have the “approve all” button when everyone in the report is cleared out

@DonovanMcNeil I am game to try this!


From the pack page select export > advancement. Then open the file and filter on the approved field to see any zeroes. Is anything there?

yes, I have a few 0’s.

Interestingly - there are some that are NOT appearing in the pack “needs approval” report.

I confirmed in connections manager that I am connected to every scout in the list

For the zeroes that didn’t appear in needs approval, what type of items are they? Are you able to see them from the scout’s advancement or awards pages?

Cub Scout Outdoor Activity Award v2015+ (Tiger) #
Cub Scout Outdoor Activity Award v2015+ (Wolf) #2a
Cub Scout Outdoor Activity Award v2015+ (Wolf) #2a
National Summertime Pack Award pin (Tiger Cub) #2
National Summertime Pack Award pin (Tiger Cub) #3

Are you able to see and approve them from the individual scouts’ awards pages?

It was for award requirements where the award is already marked off as “earned” so maybe that is intentional

I am able to approve them individually