Baloo Builder Issue

I have scout who completed the new Baloo the Builder. I entered it using the quick entry in web app (2024 version selected). All the requirements show as complete when you look at the details. But on the adventure summary it shows as not started. When I look at on the iphone app it shows it as a required adventure instead of elective. Not sure what I need to do to get it completed.

Not sure why I can’t reply to the message - So I am editting the original:
I am on 2024 version of requirements. I am not trying to catch up, I was entering something that was earned at Day Camp. This was the adventure I entered for one of five scouts. I tried Quick entry since I thought it would be faster. I entered this for my own scout to try it. When it had this issue, I entered the others with the standard entry and they worked fine. There was something wrong with the Quick Entry method, I think. I won’t try using it again! How do I get the issue with my Scout fixed to show it complete. I only referenced the parent app on my phone, because I was trying to figure this out. Thanks,

1 Like

Well there is NO app for leaders - The Parent/Scout Scouting App does not fully support the 2024 version for cubs yet. Leaders should be using It sounds like the Scout is on the old Bear Rank Version not the 2024 version - are you trying to catch up entry from last year?