Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Cannot save some events with BBCode [url] tags

After Scoutbook domain change, can no longer save certain events if they contain [url=…] BBCode tags:

If I remove the tags, the event saves fine. If I put the tags back in, the event can no longer save.

This doesn’t happen for all events. (Here is a sample broken case: EventID=3382408)

It is not an issue with a specific URL, as that URL saves just fine in other events.

Not having that issue either. Everything is working for me as it had been prior to the domain relo.

Actually, come to think of it I do not have bbcode or anything other than the event basics.

So my apologies for the misunderstanding

I just had the same thing happen. I did the whole delete the entire cookie history and temp files.

1 Like

Same issue in incognito…

I’m wondering if it has something to do with the full path you’re trying to go to. Does it work if you just go to scoutbook.scouting.org?

I don’t know if there is another way. To get this, I was updating an activity in January, clicked edit, changed the body text, and hit save. The normal edit activity work process. I don’t think I can choose the url.

1 Like

Matt,

I’m trying to reproduce this but have not been able to. Does it fail with Google This was the URL BBCode I tried.

It worked correctly with both a new event and editing an existing event.

After some crazy trail and error…

It is something to do with an apostrophe not in the URL, outside, and before.
Crashes: Google’s online
Doesn’t: Googles online

Thanks Matt.

Unfortunately the bug appears to be intermittent as some of my tests failed while others saved properly. I have reported it.

1 Like

Confirmed. If I remove all apostrophes from the event details, then I can include url tags and save without issue.

1 Like

I found a slightly different but related issue. If I had the URL tag defined as the following in the event, it would say the link was too long.

[ url=https://docs.google.com/document/d/1eYsBj1kLkIB60soK0vB5xmgp9C2rmRiuMy97CMKPVw8/edit]FAQ[/url]

However, if I did not alias the url and did it raw like the following it would work fine.

[ url]https://docs.google.com/document/d/1eYsBj1kLkIB60soK0vB5xmgp9C2rmRiuMy97CMKPVw8/edit[/url]

Please note I added a space between the [ and url so it would show the raw text in this post and not get translated.

Same issue here – tried removing the " ’ " from the event title but still getting an error. Here’s the error message:

" Requested URL cannot be found

We are sorry, but the page you are looking for cannot be found. The page has either been removed, renamed or is temporarily unavailable.

404 Not Found

Reference ID: fa17484a-3359-11eb-9a90-0ec7910dc74e

[Back to previous page](javascript:history.back(1)) Proceed to homepage"

I also created a new thread – before I found this one! – over here >> 404 error creating a PLC meeting with Reference ID error

Just confirming that I was able to create the event and save it when I removed all of the BBcode from the event description.

1 Like

Same here: Removed all BBcodes, and it finally saved.

@JoeMcKinley @Matt.Johnson @AnthonyVerguldi_Jr @bryanscouting @ThomasFellrath

Can you test this again? Since last night’s update, I am not able to reproduce this issue either in production or our test environment.

After a few basic tests, I cannot reproduce it anymore either.

This seems to work for the situation I had experienced with the URL aliasing not working.

It does seem to be fixed.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.