Can't Reassisn a Scout to a different Patrol?

I don’t seem to be able to reassign Scouts to a different Patrol anymore, has something changed?

What are your roles in Scoutbook? Also, what is your current registered position in my.scouting? If one of those is fouled, then it’s likely the cause of the problem.

ETA: I should have clarified that I tested and was able to reassign scouts using Reassign Patrol in Scoutbook.

My positions are as follows:
Scoutbook - Asst Scoutmaster & Key 3 Delegate (Both expire 12/31/2022)
Scoutbook - Asst Scoutmaster, Key 3 Delegate & Troop Admin

I was able to reassign prior to September but have not been able to since

Hrm. I’d try this first:

Go to Scoutbook → My Dashboard → Administration → My Units → Unit ### → Roster → your name

Select your Unit Admin role, make sure it’s showing as Approved, then save. This should reset that role. It’s path dependent, so you can’t just go via My Positions.

Sometimes, Unit Admin roles get glitched behind the scenes, but look fine. Resetting them this way usually fixes whatever happened. That said, the Key 3 Delegate role should have provided that access as well.

Nothing seemed to work. We even had the Committee Chair remove and then add the Key 3 and Troop Admin Role, Any other ideas?? I had him Reassign a Scout and his worked fine

Is this for all scouts or a specific one?

I have tried multiple Scouts from different Patrols and each time I get the same “Oops something went wrong and the webmaster has been notified” message

@ScottOBrien have you tried in a private or incognito window?

Just tried and got the same error message

Could you please detail the steps you are taking to reassign patrols?

I am signing into my Scoutbook Account, then under My Unit I click of my troop. From there I usually click on one of the patrols then click on a scout. Once open I scroll down to Account Membership. From there I have tried both Teassign Patrol Buttons one under BSA Membership and the second under Current Membership. The box pops up and I choose the new patrol and the reassign and that’s when I get the error message

1 Like

Try going to the roster for the target patrol, and selecting the Reassign Scouts button. Then select the scout who’s moving into the patrol.

1 Like


Thank You as that way finally worked!!! Have A Great Holiday !!!


@ScottOBrien - that is the best practices way to go

1 Like

Glad to hear it. As @Stephen_Hornak noted, this is the intended method to move scouts between subunits (or into subunits when first joining a unit).

There are a couple of things that can go wrong using the method that you outlined. One is that the membership (and associated connections) may be interrupted in Scoutbook by ending the existing membership (i.e. putting end date on existing membership) before adding the new patrol membership. Sometimes, having multiple memberships in one unit can confuse the software and impair connectivity. It hasn’t happened often enough (for me anyway) that I saw a pattern in it (other than happening when I tried something similar to what you described).

1 Like

I’m glad we found a workaround. There’s still something weird as the method used should work, but I was not able to reproduce the whoops. Ideally, we’d have something solid to report to the developers. Did the scouts have more than one active current membership when you originally tried to reassign them?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.