Error Trying to Run Advancement Report

I can edit the Advancement Report, but when I try to generate the report I am getting the error:

Report could not be loaded. Please try again.

I then see an error message come up:
“Id” must be a number, “id” position 1 contains a duplicate value
I have no idea how to fix this one.

@TodFiler - where are you accessing this? or

Any chance that this fix addressed the issue you were seeing, @TodFiler?

You likely need to force a reload on the page and/or clear your cache to make sure it’s picking up the latest updates.

Try it again and see.

I cleared the cache and tried again, but still have the error. I am running it from

I reset your admin connections, try again

If you are still have issues, which troop are you trying it for?

Yes, I am still having problems. I logged out, and cleared the cache and it still has an error. The problem troop is 3015.

I’m having the same issue currently as well. I signed out, cleared my cache and still am getting the same thing.

So I can run an advancement report:
Screenshot 2022-05-23 200716

but I also get this at login:

I had the same error message in your screenshot at one time. I refreshed and I didn’t see it again.

I am getting the a similar id error after it is not generating the advancement purchase report from
Error “id” must be a number,“id” position 2 contains a duplicate value

I have tried logging back in several times. Please help!

@CynthiaBohner - how to clear cache

How do I clear the cache?

Thanks for the instructions! After clearing my Safari history and I think I cleared my cache, now it is hanging up and I am not getting any response back from the system. I did reload the page a few times with no change. So I returned back to the previous open tab showing my advancement list and shows same id error shows up.

Any other suggestions?

Have you checked your official registered positions in your profile at I’m wondering if something is wrong with your registration/assigned functional positions.

They shouldn’t have changed as I have been able to run an advancement report for the Troop back in January. I will check but what I am exactly looking for in my profile?

Depends on your registered positions. If you’re one of the unit Key 3 (CM/SM, CC, COR), you should have access. If you have the functional position of either Key 3 Delegate or Unit Advancement Chair, I believe you should have access. I don’t think that other positions have access to run reports in IA2.

ETA: Functional positions are assigned by the Unit Key 3 or Key 3 Delegates in the organization manager at my.scouting (not in Scoutbook).


Can you please provide the unit number you are associated with please?

My profile still has me as the Unit Advancement Chair. So has to be another reason which my local council is looking into it.

Thanks for your insight!

1 Like