Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Error message in Internet Advancement

I used a third party software (not Scoutbooks) to create and successfully upload my advancement report to IA2.0 two days ago. Although the file indicates it was successfully processed, I am unable to access it in order to print the file I need to give to the Scout Shop. I thought there was just a problem with Scoutbook two days ago but now I am seeing the same problems and wondering if anyone else is experiencing problems and if there is an estimate as to when the problem will be resolved? Or if there’s something I need to check on my end?

It’s not just you. I tried to run a report for a Scout’s Eagle Binder and I keep getting “Report could not be loaded. Please try again.” along with a “Error” message on the main page.

Hoping the glitch gets fixed soon. Scout needs his report and I need to run my purchase reports for the Scout Shop.

@MerrillBiesada & @LaurieSanchez - I am able to run all of the reports available in IA2. This is successful for me @ 11:14am EST on 11/21. Now I will state that I am the CC for the Troop and Crew and Key 3 delegate and Advancement Chair for the Pack.

I’m the Advancement Chair and IA displays my position as “Troop Admin”. But I’m still getting “Report could not be loaded. Please try again.” And when I log into IA the red outline box with “Error” displays.

@MerrillBiesada - could you have a key 3 verify the role of advancement chair and if possible add key 3 delegate to your effective/operational roles in my.scouting.org. I should have also asked had this worked previously ?

@MerrillBiesada In Internet Advancement, try clicking on the fleur-de-lis icon in the upper right and see if you can switch to your Unit Advancement Chair role.

@JenniferOlinger @Stephen_Hornak
Last week I had no trouble running reports. Nothing has changed on my end or in my designation. Last night, I went to run a report and nothing. Tried again today, and still nothing.
I haven’t posted to the Forums before, so please excuse if I’m doing this wrong. I will try to upload screen shots of my IA and Scoutbook roles. While Scoutbook shows I’m Unit Adv Chair, IA only shows Troop Admin. But it’s been that way for a while, and I didn’t have any issue until yesterday.

@MerrillBiesada - Please have a unit key 3 verify in my.scouting.org in Organization Security Manager that the role of Advancement Chair is still listed for you. As this is recharter time, that may have ended. They may also want to add you as a key 3 delegate… their choice.

Why does it seem like I have asked this already… because I did.

1 Like

Thank you for the responses.

I checked my profile in my.scouting.org and I am a Committee Member, Key 3 delegate, and Unit Advancement Chair. In scoutbook.scouting.org my position shows as Key 3 delegate.

I have been able to process advancements before, as recently as October, without a problem. And, even a few days ago, it appears the advancements were actually processed - it’s the report I can’t generate. As @MerrillBiesada said, when I try to generate the report I get the message "Report could not be loaded. Please try again.” I also get a red “Error” message on the main page.

@LaurieSanchez - so I gather your profile data matches or is similar to mine:

It would seem to me that I am just talking to myself or talking into a corner… oh well

@Stephen_Hornak @JenniferOlinger @MerrillBiesada

Yes, Stephen, my profile data is similar.

I am not sure what you mean that you are talking to yourself or talking into a corner?

@MerrillBiesada

I was able to find a work-around to print out an advancement report. It looks a little different than the one I usually give the Scout shop but it should work.

You can try the following:

go to scoutbook.com

click on “login” and enter your info

go to “my dashboard”

under Internet Advancement

select Reports Menu

under Dashboard Reports Menu

select Needs Purchasing Report

select View Closed PO and find the report you need

You should see a “print” option in the upper right corner of the page

you can also scroll to the bottom of the page and click on Advancement Report. You can print the advancement report there, too.

Above the Advancement Report link there’s also an option to “Re-Open Purchase Order”. I did that as well and then went back to https://scoutbook.scouting.org and then tried to print my report as I normally do. It worked for me. When I logged out and logged back in to try it again, though, I got the red error messages again, so this did not fix the original problem but at least it did get me the Advancement Report.

@LaurieSanchez Thank you! I followed your directions and was able to generate a report to purchase awards. Interestingly, when I re-opened the purchase order and then tried to go back to IA via scoutbook.scouting.org, as you suggested, I was still not able to generate any reports there, and got the cascading loop of error messages. So I went back to the My Dashboard in scoutbook.com, clicked on Internet Advancement, and this time, instead of showing me the Reports Menu, it took me straight to IA. I then got a “Welcome!” pop-up with the Tutorial. I clicked through the Tutorial, and now the Error message is gone and I can generate reports.

I really appreciate your work-around, and will save it in case this happens to me again.

Since our COR / Admin says no changes were made to my profile and I still showed as Unit Adv Chair in the Org Security Mgr, I have no idea why this glitch happened. But all good now, thanks to your help!

@MerrillBiesada Oh good, I’m so glad to hear this helped you out! And glad you were able to get the error messages to go away.

I’m still getting those cascading error messages but at least I’ve got a work around if this problem is still present the next time I need to get awards.

Thank you Laurie! I had the same problems with the cascading error messages and not being able to print our IA report yesterday and today. After spending entirely too much time trying to find a workaround, I found your discussion thread here and your workaround worked for me!

@DarcyKendall That’s great news, Darcy! I’m glad I could help.

Does anyone know, is there somewhere we can report this problem so it can get fixed? I’m just wondering if this is a problem that many other users will experience the next time they need to print out an advancement report. I hate for more people to spend time on this, and potentially not be able to get awards for their pack or troop.