Hello! I am getting errors attempting to use the den leader experience. Using the sample logins on a PC with firefox, chrome, or edge browsers I get ‘your role needs upgrading’ errors. On an iPhone/Safari the page either is blank or directs to the regular scoutbook login screen. I’d like to use this with new leaders for training.

Using both:


What you’re showing is the demo environment. Is that what you intended to be using?

While I personally dislike the Den Leader Experience (based on how many complaints I see about it), the address for the production server is here: Scoutbook - Den Leader

Same as what Charley posted:

I am attempting to use the demo. These are links built into cub leader training materials. Thanks!

Got it, @Kelly.

@JenniferOlinger, I can confirm that I see the same error message when I try accessing the training environment using the first two “canned” credential sets, in both Chrome and Firefox, regular and private/incognito windows.

It seems to work for the third set of credentials (ppcraig***) in both browsers, with or without the private browsing window. Are you seeing the same behavior, @Kelly?

Same results @CharleyHamilton on pc in Firefox… the pp_craig user works for me as well. Tried the first two sample users and moved to another browser…that’s good to know… thanks…

I have reported this to the developers.

1 Like