Internet Recharter will not open

I am trying to do our Troop’s internet recharter (I’m the Scoutmaster). When I click the internet recharter button in internet advancement, the wheel continues to spin but the page does not load, so I am unable to take any action on the recharter. Our council would like us to have it complete this week!

Can someone give me any hints/tips to overcome this issue?
I am in Troop 30, Gulf Coast Council. BSA ID 126958436. Thank you!

Try an incognito window

I just tried that, it still did not open. I had hope!

I don’t think it should serve the button if you’re not in the correct role, but can you confirm that your SM role is selected under the fleur de lis in the upper right corner?

Hi Charley. I made sure I am using the tool in the role of SM. Last week that functionality disappeared for me but it has been restored.

1 Like

Try a Shift + Refresh of the page

If shift + R doesn’t work, I’m seeing that you have key 3 delegate and registration inquiry functional roles active for troop 30, in addition to being SM. Those are redundant as being SM gives you all the permissions you need. It’s possible, the system is getting confused by that. I’d suggest ending those functional roles.

The council office reset recharter for our troop and now I can get in. Problem solved, not sure how problem was created but I’m off to the races. Thanks all for the suggestions.


This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.