Report Builder First Class Error

When running First Class advancement status report. The % shows 0 for some scouts (4 out of 15) even though many requirements are completed and approved. Only happens for First Class Have selected Ranks, First Class, Show % Complete. The percentage for rank is correct in each Scouts Advancement Page . Have tried remaking report with other options.

Mike V

are all the Scouts on the same Year version of the rank?

Yes, Both First Class & First Class v 2016

Is Scoutbook showing a non-zero percent complete for these Scouts?

It’s showing 0% complete for First Class only, all other rank %'s are correct. Is that what your asking? I run reports by Rank and Patrol in addition to all scouts in Troop. Same 4 Scouts show 0% for First Class in any report I make. So it’s limited to those 4 scouts. Anything else I can check or refresh?

Ed means if you go to the Scout’s advancement page, what does it say for percent complete on First Class?

As mentioned in my first post, The % complete for First Class and all ranks is correct in the Scouts Advancement page. This bug showed up after the home page was recently updated

I Just figured out how to force a recalc, I went into 1 of the affected Scouts First Class Advancement page and checked off additional requirements. Ran the report again and only that scouts First Class % was corrected. Went back and deleted those requirements I checked off. Reran the report the % remained corrected.

Will leave the other 3 scouts with 0% in case SB wants to troubleshoot Will report if this bug shows up again.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.