Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Scoutbook Internet Advancement (Activity Entry Page) Not Loading

Scoutbook Internet Advancement (Activity Entry Page) Not Loading since last update or maintenance last week. I have tried multiple browsers clearing browser cache, etc. MB entry still functions correctly, however, the activity page, whether for Troop Quick entry or Individual Scout entry refuses to load.

https://advancements.scouting.org/

1 Like

There is a known issue that is preventing some people accessing the activity logs from Scoutbook. After clicking on the activity log menu item in Scoutbook all they get is a spinner. The programmers are working on the fix. The earliest we expect the fix in production is sometime Monday.

I do not normally complain about inconveniences, but this is an exception. This is really frustrating as it is a REOCCURENT problem, going back to the initial launch of 2.0. Forums have the same complaint listed since 2019. Thank you for letting us know that Monday I will be able to add activity of a Scout who’s membership as a participant closes Monday morning. Hopefully this doesn’t affect her being awarded the awards she is eligible for from her conservation hours today, but I do appreciate an actual answer instead of the typical troubleshooting advice that ends with an email to support which autoreplies that they don’t support volunteers anymore.

1 Like

Apryl,

To set expectations, we do not know that the problem will be fixed on Monday. This is the earliest is may be fixed.

Ed:
Same problem as reported above.

It would be helpful if the developers would put up a flag indicating that there is a problem. Its a lot less frustrating to users if the issue is announced - at least we know that it is being worked on. Otherwise, it becomes a new issue for everyone who is trying to use IA2.

Chuck

1 Like

They have added a flag - I didn’t see it until last night after many hours of trying to reload and reaching out to other leaders in my pack. The flag doesn’t add much detail other than, they know.

The programmers made some changes, please try accessing the activity logs and Internet Advancement again.

1 Like

It worked! Huzzah - Good on the developers for getting that corrected. It’s weird that not all hike activity transfers over from old Scoutbook into the new format, but alas. It is what it is.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.