Suddenly can't click into 'next rank' for scouts

Hi I’m the advancement chair for our troop.
The last few weeks, I have suddenly not been able to record boards of review. Whenever I go onto a scout and click on “next rank”, I don’t get an error or anything, it just takes me back to my Scoutbook home/landing page.
Here’s what I have tried to no avail:

  • log out and back in again
  • try from a different browser (happens on both Chrome and Safari)
  • try from a different computer
  • try using Incognito mode in Chrome
  • try different Scouts
  • try getting to the Scouts different ways (through patrol list or through troop roster)

In all cases, I get the exact same behavior.
Any ideas?

thanks in advance

% to next rank is broken - just go to the Advancement tab or use Quick Entry

OK, thanks. That worked!
I was actually unaware you could click on the rank badges under Advancement and get there that way.

LOL - the entire SUAC was unaware that % to next rank was a link

1 Like

Haha – I guess I get the design. Clicking on the % takes you to the rank they’re currently working on. Advancement takes you to ones they’ve already completed.

I think you misunderstood, if you are on the scout’s page and scroll all the way down, you can click [scout name]’s advancement.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.