Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Cant input rank advancements

Scoutbook shows where my registered youth completed their past rank (from 2019-20) but will not show/ allow me to put in anything they have completed for the rank they are currently working on other than my AOL who were previously Webelos. This is a new problem since our recharter was completed

I click on the info and it says update the rank in the Scout’s profile, but there is nowhere in the profile to do that (I’ve tried inputting their current grade but that did nothing).
These are Scouts who I have put information in for for the rank they are working on this year since they completed their previous ranks last summer.

Are they assigned to the correct den level?

I got some other help and we got it after a LOT of clicking to figure out! I had to advance all of the dens and that solved the problem. I didn’t think to do that before because these Scouts WERE listed as their correct rank and all before Recharter. Still not sure why it reset it all to prior to last year, but I’ll just have to go in and double check everything.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.