Unable to view the 2005 requirements from the Citizenship in the Nation Merit Badge

When viewing the Citizenship in the Nation Merit Badge, I can not switch to my 2005 requirements. It sends me back to the home page instead of sending me to the actual requirements.


I just tried this on a few Scouts and all worked as expected.

Check the Scout’s Membership page to make sure there is not an open membership in a pack. The behavior you are seeing is often an indication of a pack membership.

Screen Shot 2022-07-18 at 11.09.47 AM

The dark one is the one selected - which is dark?

2022 is dark and when i click on 2005 it sends me back to the home page

It is behaving properly - you have no requirements for Nation - so you would be doing the 22 version as the previous one is not started in scoutbook

But I already completed the 2005 requirements and talked to my counselor about it. I need to put those into scoutbook.

Talk to your unit leader - if they approve it they can enter it


There may be an issue switching the version from a Scout’s Scoutbook account. Ask your unit leader or parent (if connected in Scoutbook) to try to switch the version from their account.

Alright Ill try that.

yeah it fails from youth accounts - it has been reported to developers - not sure if/when it will be fixed

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.