Bad Request in IA Quick Entry

I have swim test updates from Summer Camp and wanted to approve relevant 2nd Class and 1st Class requirements. Using Quick Entry in IA I selected Second Class, 2022 Version, then selected 39 Scouts and the swim requirement 5b, clicked “Apply,” then confirmed that was what I wanted on the next screen but then got “Error Bad Request.” Tried on a single Scout with same result. I am Key 3 Delegate, Troop Admin, Committee Member.

Try holding down SHIFT and refresh the page

Donovan: At what point in the process to do that? I tried after getting the error message and it just sent me back to the beginning of Quick Entry. I checked the one trial Scout and it did not populate the approval to his advancement. I am running Safari 16.5.2, MacOS Monterey 12.6.7 on a 2014(!) MacMini.

Safari is likely half the issue - try Chrome or Firefox

OK. Thanks! In the near term will provide the info to our Troops’ advancement chairpersons to try but will look into installing alternate browser. Always appreciate the prompt assistance received here!

1 Like

Requirement entry should not be in IA yet. That functionality is in development. Looks like part of the functionality was prematurely moved into PROD. BSA IT has removed it to reduce confusion pending an official release of all the requirement functionality in Internet Advancement.

1 Like

Thank you! Is there a “Quick Entry” functionality in ScoutBook vs IA for rank advancement? I am familiar with what is there for Merit Badges but not ranks?

Yes, there is Quick Entry for rank requirements in Scoutbook. However, you might need to be a Troop Admin or Patrol Admin in order to access it.

I am Troop Admin. Where might I find it? Thanks!

Log into
Click on your troop
It is on that page

Quick Entry is also available on the patrol pages.

Thank you William and Jennifer. Was right there and I just didn’t see it! Really appreciate the volunteers here that help us navigate. Certainly exemplary of “A Scout is Helpful!”

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.