BSA History Report showing items as pending leader approval but they are already approved

I am generating a BSA History Report for a Scout that is close to applying for Eagle and several of his merit badges show the asterisk indicating “items pending leader approval” despite the fact that they are all marked as Completed, Approved, and Awarded.

They were all originally marked as Approved and Awarded by “BSA Administrator” so I thought that might be causing a bug in Scoutbook. I chose 5 of them and tried a few things:

  1. Unchecked Approved and Awarded, saved the Merit Badge, then re-checked Approved and Awarded. It then shows in Scoutbook that I approved and marked it as awarded (i.e. not BSA Administrator).
  2. Removed the Merit Badge altogether and re-added it, then entered a completion date, Approved, and Awarded. It then shows that I marked it as completed, approved, and awarded.
  3. Removed the Merit Badge, re-added it, entered a completion date. Then it showed that I had marked it as Completed - I had a different unit leader mark it as Approved.

None of these has made any difference and they all still show up as “pending leader approval” on the Scouts BSA History Report. If it makes any difference, they ALL show up as “Awarded” in IA (which is correct).

Any ideas?

@JamesEnfinger - i suspect prior versions

Thanks for the quick reply - I appreciate it.

I should have mentioned that, too - when I deleted and recreated the MB (Chemistry), I did notice later that I had created it with the 2020 version and the completion date was 2018. I tried deleting it and creating it with the prior versions, too, but still the same problem.

Do you know the relationship between what is expected in the report and prior versions? I would hope that the original “BSA Administrator” approval that occurred back in 2018 would have been appropriate for that time, but I don’t really understand what the report is looking for now in 2023. Do all the MBs have to be saved using the latest version?

@JamesEnfinger - my understanding is that it will look toward the current reqs, but should show completed/awarded on those items completed/approved/awarded on prior versions if done prior to a change.

It looks like a display issue somewhere, but not quite as straightforward as I had hoped. I see the same thing for one of my scouts (BSA ID 127967393) with the following MBs:

Climbing (app’d by BSA Admin)
Fishing (app’d by BSA Admin)
Geocaching (app’d by unit scouter)
Kayaking (app’d by BSA Admin)
Leatherwork (app’d by BSA Admin)
Photography (app’d by BSA Admin)
Search and Rescue (app’d by BSA Admin)

but only in the Eagle Rank portion of the report. They don’t show the asterisk indicating needs leader approval in the MBs completed portion of the report. Not all of these were Leader Approved by BSA Administrator, although most were. At the same time, other MBs, which were approved by BSA Administrator, are not showing us as needing leader approval. Like I said, not a clear cut as I had hoped.

The report ID for this is ref: PD-20231107140401-506989-623460

Maybe someone who has more visibility into the back-end can tease out what’s going on. It’s not urgent on my end, but I figured since I had an unaltered condition that might shed some light, I’d pass it along.

ETA: Oops. I missed that there are also MBs that show up that way in the Eagle Palm segment of the report.

Canoeing (app’d by unit scouter)
Metalwork (app’d by BSA Admin)
Motorboating (app’d by unit scouter)
Signs Signals and Codes (app’d by unit scouter)

Based on that additional data, I’d bet it has something to do with Eagle Requirement #3 and Palm Requirement #4 not being Leader Approved (yet).

I have duplicated the issue and I believe it is because Eagle req 3 and Palm req 4 are not approved. I’ll pass this on to the report developers to fix.


@JamesEnfinger - thanks for catching that one and reporting it

Thanks, everyone, for all the replies. I appreciate you all looking at it and reporting it in!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.