BOY SCOUTS OF AMERICA

Scouting Forums

Calendar Import seems successful but doesn't actually add entries

Hi there! First time trying to use the Assistant to create calendar entries. After fixing the CSV to no longer generate notices about bad data, it now is accepting the CSV but no success message and no calendar entries. Even trying with a super simple entry like below:

Calendar,EventType,Name,Location,StartDate,StartTime,EndDate,EndTime,RSVP,Permission,Leaders,Parents,Scouts,Description,Reminders
Pack 3152 Lion Den 6,Den Meeting,Den Meeting,OLQP Church,10/15/2019,6:30 PM,10/15/2019,7:30 PM,off,off,off,off,on,6d 1d 4h

When you look at the calendar, have you selected the Lion den 6 calendar from the gear?

Yes, I have all calendars enabled in my view. Is there typically a “success” message that should appear?

There is not a Success message, but the menu disappears and unblocks the page.

One thing I have not tested and don’t know if it will impact things, is the order of reminders. In my examples, I show them in order from shortest to longest time, yours are reversed. It is possible Scoutbook doesn’t like that and isn’t returning an error. I will do some testing.

Your example is also missing the description field

I did try adding a description for testing with no success.

I found the issue. Scoutbook made a change that requires two adults to be invited to any event, and produces a new error if they are not invited. The extension is not catching that error. I am looking into what needs to be done to fix.

I just tried setting the leader, parents, and scouts to “on”; still with no success.

I set them both “on” and it worked. Are your parents connected to your scouts? Can you manually create an event for that Den?

Hi Gary - Yes, we are able to manually create events for this den. Every scout has a parent connection, however, some of the parents have not yet completed their login for scoutbook. We are, however, able to email those parents via scoutbook and they confirmed they are receiving event reminders for manually created events. I’ll add, this is an issue for each den, not just the Lion den. I even tried with a den that has every parent connected to each scout as well as the Pack’s calendar and still no luck.

As another test, I exported the entire list of events, removed all but one from the CSV, deleted that event on the calendar, and tried to import the event that was just exported; still same problem.

The requirement to have parents and/or leaders enabled on the import corrected the issue.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.