Can't Access Legacy Tools

In the last 48 hours, I have not been able to access the Legacy Tools for my units. I am the Committee Chair for Atlanta Area Council Pack 236 and the COR and Key 3 for AAC Troop 463. Is there an issue?

*1) Desktop: Inspiron 3847
*2) Windows 10 Home
*3) Firefox 114.0.2
*4) Yes
*5) 2135382

Chuck Olson

I had the same problem.
Check this post.
Legacy Dashboard does not load

1 Like

I just saw the solution that @edavignon posted about this issue in Legacy Dashboard does not load. Please ask the developers to add an instruction to the home page that tells users how to access your units and remove the non-functional “Legacy Dashboard” tab.

Chuck Olson


Can you pass this on?

Logged on as a National or Council level, I do not see the “Legacy Dashboard” menu item any longer. I suggest you clean your cache and use a private browsing window. (“Private Window” in Firefox.)

Out of curiosity, what’s the date of the legacy data? When did the new data started on?


I see Legacy Dashboard under Recent Tools. The root cause of the problem is in the pull-down under Menu there is an Organization section. It is NOT obvious that you need to click on this drop down under Organization to see your unit tools. It is a terrible UI design.


@edavignon - here is what I see, can you send me a screenshot of what you see, AFTER you have cleared your cache.

It does show a drop down arrow on the Organization.


In an incognito window I don’t have a Recent Tools, however, we should NOT be expecting users to clear their cache. needs to work for novice users. Knowing to clear a cache is an expectation of expert users.

The bigger issue is the Organization drop down. If this is not expanded by default, which for many users it is not, they do not realize it is a drop down and need to click it to see their tools. This is what I see in an incognito window. A novice user may not realize they need to click in the box under Organization to see anything.

On organization - perhaps a better way to say it - by default it shows like you are viewing the organization without any of the apps. Perhaps defaulting the National is the main issue, it is more intuitive if it starts on unit or district

@DonovanMcNeil @edavignon @RonaldBlaisdell
After clearing my cache, this is what I see:

Legacy Dashboard is still showing but is inoperable.

I agree with Ed that the real issue is that there is nothing in or around the “Organization” section that alerts the user what that section does. I would suggest two things that would help clear up the confusion:

  • In the home page, post an notice explaining that the Legacy Dashboard tools are now located under the “Organization” section.

  • Rename the “Organization” section to “Organization Tools.”


I have a COR (BSA ID 6305929) with a similar problem. His units are not listed in the Organization drop-down, and he cannot access Legacy Tools. He needs to approve an adult application. He’s tried different browsers & clearing caches. Suggestions?

Does the COR registered position show up in their My Profile registered positions list at my.scouting in the account they are logging into?

Yes. He had full access at least 2 weeks ago, but now Organizations only lists the National Council. When he tries to use the drop-down, he gat a 404 error


I can see it, if not modify it, as a Key 3 Delegate. Has he tried navigating to My Profile, then trying the organization drop-down again? I wonder if the code isn’t reading the registered positions reliably, and forcing it to load the positions to display in My Profile might bypass the issue.

@NancyHodgkiss I would suggest he log in here for assistance - sounds like a simple screenshare is needed

Craig W, our wonderful volunteers at SUAC request that you log into Scouting forums on this thread to try a screen share with them.

The issue turned out to be a Firefox issue with the org drop down in the menu of my.scouting.
When he tried to scroll, My.scouting would crash. He was successful in getting all of the units in Chrome. We passed this info on to National.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.