Den Not Found

My spouse, my cub scout, and I have all signed up and installed the app. Advancements work on the web for us all, but not on the app. We’re all getting ‘Den Not Found’ on the Advancements tab. We tried changing our Requirements year to a different year and that didn’t fix it for any of us (and I did that over a week ago). Any other suggestions? Ty for your help!



BSAIT had to prioritize getting the new Cub Scout program into Scoutbook Plus. The Scouting App has not yet been updated for the new program. Use


Mine said I have to have an admin setup my Dens. What if I can’t get the admins to do that? This so far has not been user friendly. The den leaders should be able to set up a den.

@KerriWatts - this has always been an admin task to set up dens as they have access to the entire roster. I suspect though the error is due to the lack of completed integration of the cub program in the app.

1 Like

@Deborah can you please post you and your Scout’s MID so developers can test the fix when it’s closer to release? Thanks!


Let me know if I can help test (lead application developer and previously software qa tester). Thanks!

I am having this same issue. I am a Key 3 and this issue is only with my AOL son. My Bear son shows just fine. It seems to me that there is some issue with AOL dens that we are not having with other ranks. If I make the den a Webelos den then I can see it, but if I make it an AOL den then it is very glitched on both the app and the site and parent side and the admin side. I have tried making a new AOL den and transferring the scouts to that but the issue persists.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.