Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Scoutbook Bugs or issues

Anyone see this?
I log in successfully, see my 3 sons, see all the Scouts that I am DL for. I click on their name, then a new screen comes up, that normally does. I click on the progress bar to see where they are lacking in completing adventures, and then it just bounces back to “My Dashboard” again.

What gives? I am trying to see what specific items the Scouts are lacking as we get close to the end of the Scouting year.

Please help.

It looks like you have a Den Leader position that is not assigned to a Den - that could be causing the issue and is the place I would start with a Unit admin. Or just end the position your self if it is Den 5 you are trying to access as you are already Den admin of 5. Then fix the other later

Sorry, but I don’t think this is the case. I have been a den leader all year long, and have been monitoring all of the 2 den’s status and entering in their accomplishments all year long. This is a recent change. I cannot even enter my own kids in, it bounces back to the base page.

Screen Shot 2021-04-22 at 10.04.24 AM

So you are clicking this? I did not know that was even a link - I will report it - for now just go through the Advancements Tab

I got a work-around. I clicked on the Scout, then scrolled down to their “NAME’s Advancement”. I clicked on that, then it brought up a screen that shows the ranks they’ve completed and the one they’re working on. I click on the one they are working on, and then it takes me to what adventures they’ve done for this year, their progress, etc.

Thanks for your help Donovan.

Kevin

2 Likes

Yes that was where I was clicking. It worked in the past. Now I’ll just goto the advancements Tab after you scroll down. Have a good day!

Thanks Kevin, you are a life saver!

I have this exact same problem. It started sometime after Tuesday night.

1 Like

Here to report the same issue. Thank you in advance.

The best way to stay up-to-date on the bug fixes/features that have been released is to subscribe to the change logs:

seeing the same change in behavior here - it makes it a LOT harder to enter data and track the scouts when you have to click three times for each one instead of just once. Additionally, this makes the online version (on your mobile device) almost useless for quick entry. Can we please see if we can get the tool to work the way it did prior.

@JohnBarenys Is Quick Entry not working from the den page?

quick entry works fine - I find that for that you really want to be at the PC and not on a smaller mobile. Being able to quickly access one child’s advancement by clicking the progress indicator made it super simple to quickly review and enter information. It worked this way until about a week ago from what I can tell.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.