BOY SCOUTS OF AMERICA

Scouting Forums

Eagle Rank Application Report not available to Crew Scout

We are having an administration issue crop up that my son who is a Life Scout did not get on the Troop charter this year, only the Crew charter. The Troop is working with our council to have this problem solved. In the meantime, he only shows up in the Crew on Scoutbook. We figured out how to toggle on the Scouts BSA advancement, so that is good. However, under Reports, there is not an option for Eagle Rank Application. Is this a Venturing issue? Once he is back on the Troop Roster, will we be able to see this?

Since Venture Scouts can reach Eagle, it seems like it should be available to him still. He just has a few more steps to finish up and being able to populate the application would be a huge help. He really wants to finish up over the summer.

The simple work around is just reactivate his Troop membership in SB and run the report

Angela,

This appears to be a bug in Scoutbook. You can try going to the URL https://reports.scoutbook.com/vim2/webscript/output/sbreports.aspx?Method=ExecuteScriptSet&ScriptSetCode=SBEagleScoutRankApplication&ScriptCode=PrintEditablePDF&UserID=xxxxxxxx where you replace the xxxxxxxx with the ScoutUserID= value that appears when you click on his profile.

I tried using his BSA number and just got a blank report.
I tried using his First and Last name with no space and got an error message.

What is his ScoutUserID value? (sorry for being dense on this…)

@AngelaKoch to use the link Ed gave - go to the Scout’s Scoutbook page and look at the URL of the page - you will see at the end ScoutuserID= use that number in the XX area indicated.

Or just go to the Scouts membership in Scoutbook and erase the end date for the troop.

Beautiful!! Thank you!

We have notified the developers of the problem.