Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Eagle Report

I’m trying to get to my son’s Eagle report. The troop leader tells me I have rights. A pop up menu requests his BSA ID and last name. I enter that data and get an error message “Please log onto your account and try again, or report this to the forums (82).” I’ve logged out and back in several times, doesn’t fix the issue. His Eagle project is done and this is the last step for advancement. Help, please!

You mean the Eagle Application?

I think so, the function under “reports”, that’s where the troop leader said to go to submit final report after project completion. Will not let me access.

Just verified, yes, “Eagle Application”

Geoff,

Go to your son’s page then Reports then Eagle Application.

Geoff,

tell your son to go to his page then Reports then Eagle Application.

Thanks, but my son encounters the the same problem as I do.

back to old school ESRA

Do other adults in your unit have the same issue when downloading the application for your son?

I just tired for my daughter and another scout in the troop and both worked.

Have you tried in a) a different browser b) in incognito mode?

My troop leader is aware of issue and did not indicate that any other recent Eagles have had this problem. I’ll see if they’ll accept the pdf that LaurenceFoong helpfully provided. After the many, many hours of work doing his project, my son wants to get this wrapped up!

@GeoffPolma If Scoutbook is asking for his BSA member number and last name, then you are not on the correct screen in Scoutbook.

Please click on your son’s main page in Scoutbook, then scroll down to:

Reports -> Eagle Application

I just tried it with my son’s account in Scoutbook, and it worked.

1 Like

The one linked is the official application. The one in scout book is the official app, automatically partially filled out. Either is acceptable.

Thanks Matt.Johnson, JenniferOlinger, we’ve tried it from both my account and his, same error blocks us on both. Out of an abundance of caution, I sent the pdf form to our Troop Leader to verify they’ll accept pdf before my son goes to the effort of filling out the pdf. Sounds like they’re supposed to, which will solve our issue.

@GeoffPolma - if it is asking for the BSA-ID you are still in the wrong spot with both accounts.

1 Like

@GeoffPolma Ask one of the leaders in the troop to e-mail the form to you from Scoutbook. Let them know that you’re having trouble accessing the form. No need to start from scratch.

Yes, it’s sounds like you are on this page:

My Dashboard -> Reports Menu

If you try to access it there, it won’t work, because you aren’t an adult leader.

@GeoffPolma - have your son log in, then have him go to the page that shows all of his advancement stuff, then scroll down to where it says reports, click there and look for Eagle Application.

FOR THE SCOUT LOGIN:

Dashboard >> Click on dashboard >> Click on Administration >> click on my account >> click on reports

Thanks, we’ll try that. We were going through My Dashboard > Reports menu, since it said “Eagle Application” we thought that was the correct place.

@GeoffPolma - sure thing Geoff. Now from your account it would be dashboard >> administration >> my family >> your son >> then reports

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.