Entering an Eagle Scout Project in Scoutbook

A scout in our troop conducted his Eagle Scout project last week. I am trying to enter the information into Scoutbook but there are no options from the drop down menu where it asks about the type of project it is. I am able to check that yes it is associated with an Eagle Scout project and the description in the text box but in the actual type of project checkbox (which is a required field), it says no data available.

Any ideas?

Stacey Moe

Well are you entering it for the Eagle Candidate - or for Service Hours for the Troop - they are different

on the blank fields a SHIFT + Refresh usually fixes that - but that is entering it for the Unit - Not for the Scouts record - that is from their Life rank page top right

I am entering it for the scouts’ service hours for those who worked on the Eagle Scout project. Per your suggestion, I tried shift plus refresh, but it didn’t work. Any other suggestions?


Here is a screenshot of the message of “No Data” I get when I try to enter the info on the type of project it is.

Thank you!

have you tried a incognito or private window? it is often like a popup blocker that causes issues

I tried that but it didn’t work. Thank you for your help. I will try to figure it out later. Too frustrated to do any more on it now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.