Entering Partial MB reqs for summer camp (Advancement Chair)

I’m our Troop Advancement Chair and getting an error trying to enter merit badge reqs that were partially completed at Summer Camp.

To reproduce:

  1. Click on Troop → Quick Entry
  2. Select “Enter Merit Badge Req.”
  3. Select a MB … ie, First Aid
  4. I select the Requirement Version, enter Date Completed, click Approved/Recorded, select the Scout(s) and then check the completed reqs (some completed, not all) and enter a note about Summer Camp.

Result: “Whoops! We encountered an error trying to process … will fix it ASAP!”


  • I only get this when doing partial MBs. Fully completed MBs work fine
  • The # of Scouts selected and the # of MB reqs selected does not seem to make a difference … same error every time.

I have to be missing something. Any help is greatly appreciated!

Nick Streams
Troop 444, Franklin, TN

try doing without approve - then you can use approve report

Though I bet one Scout is out of sync is the real issue, or one scout still has a pack membership in Scoutbook @NicholasStreams

Thanks. I tried again without the “Approved / Recorded” checkbox, but still get the error. It does not seem to matter if I do a single Scout, a different single scout, several Scouts, etc. … every time I get the error when attempting partial MB entry.

@NicholasStreams try again I just reset your admin role

@DonovanMcNeil Thanks. Logged out, back in … same error.

can you try for a single scout?

@DonovanMcNeil - I think the OP noted that a single scout rendered the same failure.

@NicholasStreams I can setup a screenshare to help try to isolate it

@DonovanMcNeil I’m open to that. Just let me know how to join

@NicholasStreams if now is a good time I can send you a direct message

@DonovanMcNeil Now is great. Go ahead and send

I will send you a direct message > look at top right Avatar to find it > it will be a green dot with a number 1 > it will be a private message channel with select members of the Scoutbook User Advisory Council (SUAC)

@DonovanMcNeil after you and I did our screen share, I ended up getting the error again. I did some more testing and finally pinpointed the issue:

  • when doing the Quick Entry → Enter Merit Badge Req. (to enter partial MBs), you cannot include an apostrophe in the Note. I was entering “Summer Camp '21” as the note which produced the error every time; however, “Summer Camp 21” works just fine.

Note: I was able to add a Note with apostrophe via the Quick Entry → Enter Merit Badges so it is handled there, but apparently not in the Quick Entry → Enter Merit Badge Req.

I’m good now. Thanks for your help in narrowing down the issue.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.