Error Generating Awards Report

Hello, I am the Advancement Chair for Troop 753 in Carrollton, TX. I am currently having issues generating a report to bring to the scout shop for purchase of awards. I have done this in the past without issue.
I imported more records (from TroopWebHost) and they processed successfully. IA showed that I had 42 awards pending purchase. I clicked to do the Advancement report preview which worked fine. Clicking the red button at the bottom to actually generate the report fails. A separate browser tab opens which is simply a gray screen which reads “Report could not be loaded. Please try again.”. When I close that tab, I am back at the report preview screen with the preview still showing but also with an error popup which states “Unable to find the user for the given userid”. There is no mention of which userid is failing. I have screen captures if needed.

To make matters worse, I tried again an hour later. When I logged into IA, the message at the top now says that I only have 28 awards to purchase now. If I go to the reports menu/Purchase History, there are none since last year.

Thanks for your help,
Cory Bowes

Kind of sounds like you have a scout on your list that is not really registered - maybe dropped at recharter - have you checked your roster?

In Scoutbook, I do have 3 newish scouts in the troop with yellow triangles. These same scouts are not present in the roster in my.Scouting. The 3 BSA IDs are below.

I’m not sure what the next steps are to get my.Scouting updated?

MYST Transfer tool Unit.pdf (191.2 KB)
MYST Transfer tool.pdf (222.1 KB)
Either the Parents MIGHT be able to transfer them. Or the Pack can with this PDF.

A Key 3 from Troop can do an in-council transfer from Scoutbook Roster.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.