Unable to Generate Advancement Report to Purchase Badges

I am the advancement chair for my son’s troop and have delegated key three access. I have been working with IA in this role for 2+ years. This past Sunday (5/15), IA appeared to be working fine, as I had reports available to me for recent Eagles. I uploaded the advancement report for our May CoH on Monday evening and it took with no errors. I logged in to IA today to generate the purchase report needed for our CoH next week (5/26) and have no ability to generate any reports. The Eagle-related reports are no longer available to me either. I can see that all the uploaded awards show up associated with the boys, so I know they are in the system. I just need to generate the report to allow us to purchase them.

I get some strange errors upon login or when I attempt to try to generate a report. The one on login reads: “Error An attempt by a client to checkout a Connection has timed out.” That same error shows up using Chrome and Firefox. Any guidance you can provide that will allow us to acquire the badges this weekend would be much appreciated.

@ChristopherCarlson - the checkout error is generally a timeout between your session and the database. The token that authorized you has most likely expired. I would suggest an incognito session after closing all active browser sessions.

1 Like

I have the same problem. All kinds of strange errors today, but the updates I made were saved. But no way to generate the advancement report for items needed to purchase.

@ClaudiaAngus and @ChristopherCarlson - have either of you tried at scoutbook.scouting.org for the needs purchasing report and advancement reports ?

I had not, but thanks for the direction. I was able to find the Needs Purchasing Report.

posted on another similar thread, same issue
uploaded an advancement report. 30 mb and rank uploaded fine, show on the scouts, shows as processed, but no advancement report generated.
I’m poking around scoutbook instead of internet advancement, but our troop doesn’t use scoutbook specifically.
so the needs purchasing report doesn’t match exactly what we need to purchase.

Same problem - can log in and enter advancements (note - I get an error message when I log in). However, when I try to print out the advancement report, it says I need to enter some advancements. I need this report early next week to purchase awards for our CoH on the 26th.

@SharonBrown What does the error message say?

Please approve at least one advancement before running the Advancement Report.

The developers are looking into this

I am having the same problem. I uploaded my advancement report and it was accepted with no errors, but Scoutbook won’t let me generate a report.

Same issue for me today.

@JesusQuintero & @DuncanClore - this is apparently being looked at. No ETA on a resolution.

I can’t generate a report to order badges either.

The error message just says “Not found"

As a workaround, please try logging in to Scoutbook, and go to:

My Dashboard → Administration → click on your unit → Pack Reports / Troop Reports → Needs Purchasing Report

You should be able to create a new purchase order (PO), view open PO, or view closed POs.

I hope Internet advancement will be fixed soon, I can’t get any reports either and we don’t.

This is a known issue in Internet Advancement, the developers are working on a fix.

When fixed, it will be announced.

Okay thanks, I’m new still figuring out how this works.