Export advancement not working

I can export advancement for our Girls Troop and Crew, but the Boys Troop file is just HTML info in excel and not an actual excel list like the others.

@LisaBranam - i just did the export advancement for my pack troop and crew and all three were csv files

Sorry, yes all were csv files, I just opened them in excel to look and try to find the issue. The boys troop one is corrupted. I tried again today. Below is the top of what it shows when I open the boys troop CSV file. the girls troop and crew do not look like this.

" Scoutbook - Error "
" "
" "
" "
" "
" "
" <meta name=““robots”” content=““index” follow” />

@LisaBranam - what is your role in the boys troop ?

Hi Lisa,

I agree with you! I have been having the same issue for several weeks. I am the Committee Chair. The Advancement CSV that we import into our troop website used to be 4700 kb and now it’s 9 kb in size. When I open it, the old file contained data and columns with BSA ID, Member Name, etc. The new file only contains javascript, and it will not import.

@AnneWhite & @LisaBranam - could you check your browser setup and see where your download folder is ? Then go into that folder and delete all prior %unit_name%_Advancement.csv files. Or move them elsewhere and try again. I am suspecting a name collision which is not a scoutbook issue but rather an OS limitation

1 Like

I just checked my troop, and I’m also able to export the advancement backup file. When opened, it looks just fine in Excel & Google Sheets, and contains the expected data format. I tried both Firefox and Chrome on Windows successfully.

I think that the issues that @Stephen_Hornak raised are likely things to investigate.

  • Have you tried changing the filename on download to avoid name collision?

  • Have you cleared cache/forced a reload?

  • Do you both have the appropriate level of access to each of the units you’re trying to expert data from? What are your registered/functional positions?

@AnneWhite, being registered as CC should be sufficient to pull the information. Maybe reset your Unit Admin role in Scoutbook by going to

My Dashboard → Administration → My Units → Unit # → Roster → Your name

Then, select your unit admin role and approve it. It might look fine, but sometimes the admin roles get messed up behind the scenes for some reason.

1 Like

Additionally if you have 10 instances of the same filename the 11th will fail. That is something i recall from like 20 plus years ago…

Hi Charley and Stephen,
Upon your suggestion:

  • I removed all previous exports from the downloads folder.
  • It chooses the file name on download, but there weren’t any other advancement files in the download folder to cause name collision on this attempt.
  • I cleared the cache.
  • I tried Google Chrome and MS Edge.
  • I am admin and committee chair.
  • I reset my unit admin role.
  • I have exported these files successfully since my tenure began in Oct 2021. Only November 21, 2023 did it begin this issue.
  • The new file is 8k and only contains script.
  • The previous advancement file was 4 MB. We are a large troop.

Here’s a screenshot of the beginning of the new incorrect advancement file. troop-842-adv hosted at ImgBB — ImgBB

@AnneWhite - i can do a screenshare if you wish…

1 Like

Will do! I appreciate you. Thanks!

@AnneWhite or @LisaBranam can one of you search for me and add me as an admin? Just name will work. Or I can add myself to see if it is a unit issue or your user.

Hi Donovan. I added the only Donovan McNeil I could find, so I hope it was you! We are Troop 842, Circle Ten Council, Coppell, Texas.

@AnneWhite yes is me - give me a minute

@AnneWhite OK - I wonder if it is timing out over troop size? I will turn this in

1 Like

Hi I am having the same issue with Troop 998 B (boys troop). I am an ASM and Troop Web and Scoutbook admin. The advancement file is missing BSA ID is the error I get. As previously noted it looks like the script is being downloaded instead of export. I am blocked from keeping my troop website up to date on scouts and adults as I need all 3 files so this is impacting our ability to communicate with our scouts and parents. Any updates? I am happy to share the export or do a quick web conference and show you what is happening. The issue has persisted for the last 3-4 weeks (I just found this forum). @DonovanMcNeil FYI

@AmandeepBawa - how many scouts in your unit

@Stephen_Hornak - 85 scouts at the moment

This is in the backlog - we do not know when or If BSA IT will schedule or fix - families can always log into Scoutbook to see the data

@DonovanMcNeil - thanks for the update. who can I talk to get this fix prioritized? My thought is that it should be trivial to fix (probably a previous fix can be rolled back or corrected). The impact is large as it impacts how our new scouts and parents interact with our troop.

1 Like