Gold Palm won't let me record it

I’ve tried multiple times to record a Gold Palm for an Eagle Scout and I receive an error each time.

Well provide some info and we can help - what is the scouts BSA # (no names) - what is the failure you are seeing and what system are you using?


I’ve seen this in numerous areas this evening when recording items. However, this Gold Palm was the first one that didn’t actually mark it off, even though the error displayed.

I was able to get the palm marked off by recording each individual requirement, but still receive the error if I go back into the palm requirements.


I’m having the same issue. Was able to record the first palm, but not the second. Same error.

Thank you for reporting this. It has been reported to the developers.

Having the same issue for my Eagle scout, and he ages out within the next few days.

Able to log Bronze palm but not gold and silver. Get the same error message as above

I am having this error for any Eagle palm entered for a scout after the first. The first Bronze completed as expected, but not the gold, silver, second bronze, or second gold.

The individual requirements are completed and approved, but the completed date for the palm is not set and when you try to set it, it reports an error and directs to discussions.

bsa member id 129608691

@LawrenceKoenig @EmiliMorgantini @SherryAguerro - as Jacob notes above, this has been reported

I am also experiencing this with Eagle Palms with a scout that ages out the 19th

Though, unlike reported above, if I fill out each individual requirement completed date it does record it as 100% for me this is solved for now.

Same issue and scout turns 18 on the 18th. I tried to fill out each one individual as suggested by other it shows 100% complete but still does not record it.

@ChrisStewart1 - does it show up in needs approval and can you approve it?

No if run need approval report it does not show up

I have the same issue here - cannot record gold palm, and received the same error message

I am also having the same issue. Trying to approve both a Gold and Silver palm, however I receive an error message. Problem initiated on 2/4 or 2/5. It originally gave me an error message about checking dates. We verified dates on previous palms were correct. Now when I try to approve, I get the Whoops! we encountered an error message.

This is a known bug, and the developers are working on a fix.

Problem: Unable to leader approve Eagle Gold Palm even though system allowed another leader to mark the requirement (SM Conference) complete.
Symptom: Whoops Error
Scout: BSA ID: 132915549
Importance: Fix needed or presentation of Palm at upcoming Court of Honor.

Hello - I have two Eagle scouts where I need to remove the “Awarded” dates from their Gold and Silver Palms. They have not received them yet and the scout store will not let us receive their physical palms without a report showing as not awarded yet.

I tried removing the Awarded dates, but the system gives me the same error message:

Whoops! We encountered an error trying to process your request.

Please go to Scoutbook Bugs - Scouting Forums to report this issue.

As indicated above, this is a known issue that is being worked on by the developers.