HTTP POST on resource error on ACH manual payment

When trying to process an ACH payment as a manual process, add all bank information add and receiving the error HTTP POST on resource ‘’ failed: bad request (400).

did this process last year with no errors.

This error happens on both Chrome and edge browsers. Also tried in in private mode and incognito mode.
cleared cache and cookies. still receiving error.

any fixed for this issue or why is this error happening?


I am getting the same error. Did you ever find a fix?

Could you try closing all extra browser windows and use an incognito or private braising window?

I’m still getting this error today 11/30/2023

1 Like

I am still received this error as of today. Any fix?

1 Like

I think you would need to speak to your council @BrianKnobbe , @RobertShumpert @LILYRODRIGUEZ @GregWalt

I know people have had issues with this when all the address info didn’t match exactly as on the bank account.

1 Like

I am getting this error message as well and cannot submit payment/recharter. Anyone have the resolution?

1 Like

@RochelleBright-VerSt - for my units i chose pay at council and submitted checks. Otherwise contact your council

I tried making this update, but it did not seem to make a difference.

WePay does confirm the bank information as correct.
The error appears in BSA Recharter app… this is where the issue is. Can BSA check please?

‘[ ]’ failed: bad request (400).

Thats the BSA app… council would not know.

1 Like


Your Council is your first line of contact for issues with Internet Recharter. If they cannot solve the problem they can open a ticket with BSA IT. These forums are not monitored by BSA staff.

You need to contact your Council.


Here is how I got ACH to work. I entered my name and email address into the ACH form, NOT the name and address on file at the actual ACH Bank Account.

I am experiencing the same issue. I have entered all sorts of information combinations. Nothing works. I get a popup “Error: Bad Request”. This is my first time rechartering and this is quite the disappointment…

Same error here bad request prior to getting to the payment page the HTTP POST ERROR when I get to the payment windows

@MatthewCarrier - i suggest talking to your council about this issue