Issue undoing advancement marked off for Scout

Hi,

I have read of the issue where leaders have problems managing advancements for their own children. A leader in my pack ran into this with his child. I found, as leader/admin who is not a parent to the Scout, that I cannot undo any state of the Scout. At first, it was marked complete. I was unable to remove the date. Later, another leader marked approved for that adventure. I am unable to undo that action either. Is this part of the known issue?

Image below:

The issue is for Webelos Paddling Onward adventure for Scout 13888761.

Thank you,
Scott Hall

@Scott_Hall did this get resolved?

I still have Bear adventures that no one can undo. I can click and remove the Completion Date, but as soon as I select Save, the Completion Date is back.

@JillBarr are all the requirements filled in?

@DonovanMcNeil, no the issue remains in place. I am seeing similar behavior as @JillBarr described. I can interact with the check boxes and dates, but not save the change. This popped up a week or so ago and different leaders tried interacting with that entry before I posted here.

Error message when I try to unmark approved for the adventure in question:

I did experiment with another Scout whose recent advancements were managed by a leader who is not their parent. In this case, I was able to modify the entry and save it as intended. I was able to unmark and later mark again various states for this other Scout.

The error state is persisting for the child of a leader who marked off the initial requirement. Other leaders cannot undo things for this advancement.

Full sequence of my tests:

  • Den leader marks advancement as complete for their child. This was by mistake.
  • Den leader cannot undo completion marking.
  • I cannot undo completion marking.
  • CC cannot undo completion marking.
  • CC marks advancement as approved.
  • I cannot undo approval marking.
  • I mark advancement as awarded.
  • I can unmark advancement as awarded.
  • I cannot unmark advancement as approved.

All of my attempts were across multiple sessions, so the issue is persistent.

Thanks!

OK we saw a similar issue to were it was completing a Req for rank and getting locked up - that is reported

1 Like

@DonovanMcNeil No, it was originally completed using Quick Entry for a number of scouts. I entered a date for 1 requirement, saved, and it removed the “Final Completion Date” for the adventure, and reported the percentage complete as 13%. From there, I was able to undo that one requirement, and save, and now it is at 0% (where I want it to be)!!

@JillBarr hmm - trying to understand - QE for adventures now you have to enter reqs - there is not a complete while adventure option without filling out reqs. Where they just done individually

i do see the issue though @JillBarr

@DonovanMcNeil I wasn’t able to undo when only the Final Completion Date was filled in (from QE). Once I put in a date for any of the individual requirements, it cleared the Final Completion Date (it probably shouldn’t do this), and then I was able to undo the entire adventure.

@DonovanMcNeil
I tried the method @JillBarr outlined and had similar success. Entering a date in one of the requirements reset the completion info. This could be considered bad behavior if the advancement was marked complete intentionally and later an errant requirement entry resets it by mistake. There is probably some refinement here for the UX.

Sequence of events for me.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.