"Missing" Leader Approved Advancement

We have been noticing some gaps in our Scouts with Rank Advancement despite our SM swearing he entered something.

In double checking the Audit Log, it appears like something was signed off in SB but doesn’t show in SB or advancement report.

Realized that the approved rank is just showing current reqs(v2022) no longer the prior(v2016). Is it possible that the SM is marking advancement under 2016? Does the audit log show which version was used?

@DaveBuckley - nobody should be using the prior rank versions

@Stephen_Hornak Yes I understand they shouldn’t but does SB prevent it? Honestly it is confusing when reqs signed off under 2016 aren’t carried forward.

It looks like quick entry still allows for approval of prior version requirements, although my interface defaulted to the 2022 version:

I’d run an advancement report for first class rank using Report Builder, which shows all versions. That might help diagnose the issue.

Part of the reason that requirements don’t “auto-match” is that there are sometimes “subtle” changes to a given requirement number and/or the requirement was moved/broken up. As a result, it’s not a simple matter to map completion of the old requirement onto the new requirements. Rather then having some requirements carry-over and others not, I suspect that the developers determined it was less trouble to have scouters manage this directly where applicable.

Honestly I’d be surprised if the SM is using quick entry. Is that available on Ipad?

It’s available on any interface that will run the web browser. If the SM is trying to use the Scouting app, they wouldn’t see the unit at all, just their own scout (assuming they are a parent of a current scout).

Ok. Was assuming it was a FeatureExtension and that wasn’t available on iPad. Fairly confident the SM hasn’t used batch as there is a gap in the SMC wasn’t checked for some reason that I can see.

When I look at other Scouts on their Ranks not earned, they should the toggle between 2016 and 2022-3

Yeah, I’m not sure why that’s true, but I’ve observed the toggle for scouts in my own unit as recently as yesterday. I would expect any scout who has not yet completed the rank to not be served the toggle for an earlier version.

Besides the subtle wording changes there doesn’t seem to be drastic differences. That said there could be a workflow if a physical book is signed off prior to 2022, they might need to record in SB.

Our SM seems to feel the book is golden and SB is only backup. While I understand that to a degree there is a value in SB more than just backup. With some of these issues, I am not sure he will be all that inclined to keep using SB for individual requirements.

Was hoping to understand if his entry could be causing these issues.

Yeah, like I said, creating/running a Report Builder report for First Class will at least diagnose whether or not it’s credited for the “wrong” version (and thus not visible in the “current” version).

I included the individual Adv report for the missing item. Would the report builder show something additional?

I can use the report builder but its not showing anything specific to the version used. Is there a specific setting to enable that part of the report?

If I have folks on multiple versions, I usually get both identified in the report when I run it.

Yeah we have a lot on both versions. This Scout has items signed off in 2021 but there isn’t an version showing for any of the requirements. Also this is showing Req 11 still empty despite the audit log



Post the Scout’s BSA Member ID (no names) and we can look in the DB to try to see if there is anything strange.

I can’t tell from your screenshot because of where it breaks off, but it looks like this when I run a group of scouts who have different versions. Note the rank versions circled on the left side just before the list of requirement numbers.

Maybe you need to grab at least one scout who is for sure on the earlier and one for sure on the later requirements, in addition to the scout in question?

The Scouts MemberID is 136678744

Here is an example with a Scout almost 18. Guess I would have assumed Reqs approved prior 2022 be also marked under 2016 but appears its not if the rank is unearned? Not sure this shows enough to determine what occurred.


I don’t see anything strange in the DB.

The “earlier” versions usually appear after the “current” version, but if the list just terminates after the last requirement for First Class 2022, it looks like there’s no earlier version entered for that scout.