BOY SCOUTS OF AMERICA

Scouting Forums

Needs Approval Report

In response to parents getting full control (with units unable to change this), please update the Needs Approval Report to list who approved each item. As it is now, the approving leader has to go back to each Scout’s advancement / rank page to see this information, in order to ensure that completions were recorded by registered leaders. By the way, I am not a fan of that permission change.

Joshua,

This is coming. The report is being developed.

Keep in mind, Scoutbook is designed for the Scout to mark items complete, just as the Scout should be checking the left hand column in the handbook. Once an item is marked complete, the leaders should test the Scout and sign off the requirement by approving it.

Hi, @JoshuaFroimson,

As a workaround, you can more easily get the identity of the person who marked items complete (or who marked it approved) by using the Audit Log from the unit reports pulldown (shown below for my troop):

A user listed as “Unknown” for the advancement audit log generally indicates entry using the Scouting app, rather than via Scoutbook. There have been some suggestions on the forums that when using Quick Entry (possibly via the Feature Assistant Extension, possibly Scoutbook’s native quick entry) the user is similarly listed as Unknown. I haven’t been able to personally verify or refute that, so please be aware of that potential limitation.

Select date ranges that reflect what’s been marked complete/approved since the last time you audited/approved items, and away you go!

Charlie, your Audit Report was very helpful for my situation, you answered a question and created another one. I have a Scout showing up in the Needs Approval Report. The reports shows that the Scout has marked the Astronomy and Geocaching MB requirements as complete. I confirmed with Scout and his parents that he has not done this MB. When I ran the Audit log report to see who entered the information is says User unknown. How do I delete these 2 merit badges from the Needs Approval Report?

Brynne - if neither the scout nor parents entered it (I would have made then back everything out) it could have been someone using the feature assistant. Worst case is you are left removing dates from the requirements or you could go to that merit badge click on that completed bar near the top and look for remove merit badge and click on that. I do not think it clears the requirements from needs approval.

Who does the MB say approved it. If it says BSA Administrator, that means it was entered in the old Internet Advancement by someone in your troop or entered manually by your council registrar. Either way, it sounds like it’s a mistake that Scoutbook helped you find.

it says “unknown.” No sure how to make it go away.

Brynne, in Scoutbook, go to the Scout’s Advancement page, click on the Astronomy merit badge, click on one of the requirements that you want to remove, remove the Date Completed, then Save. Repeat for the other requirements as needed.

If the Scout is not working on this merit badge at all, you can just click on the “Percent Completed” button, then “Remove Merit Badge”.

Repeat for the Geocaching MB.

I will try to see if I can remove the dates. I probably just need to contact Scoutbook directly. I have several errors in ranks, MBs, and other awards that need to be fixed.

@BrynneMartinson ,

Member Care will not remove advancements for you. They will just explain what you need to do to remove them yourself as Jennifer has already done.

Thank you, this worked. It has also cleared out the Needs Approval Report.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.