Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Advancement report is missing

As usual I entered the advancements for my troop in Scoutbook. Normally at the end I would run a report to create a list to purchase at the Scout store. Today I entered lots of requirements, system approved the entries and no report can be made, since the system tells me there are no items to be approved. All requirements I entered show up in the scout’s records as approved. Is this a bug or a change?

1 Like

Are the items marked as Approved, but not Awarded?

What are some specific examples?

Do you want names? I entered 49 items for the boy troop. I was able to get a purchase order out of Scoutbook, but it was not the usual route I take.

And yes, they are marked approved, but not awarded.

1 Like

I just realized the option Completed is missing in the record advancement pull down. I can only Approve or Award advancements. I can not mark them Complete anymore. Since I marked them as Approve, they won’t show up in my Advancement report. So this must be a change.

1 Like

@Sandrate_Plate - can you provide your exact steps including the URL of your start point. Also what kind of unit and your role there.

I usually hit three locations in scoutbook.com;
Needs Approval
Needs Purchasing - shopping list and advancement report
Needs Awarding

In 6 years I do not recall a specific singular location to mark items complete unless the item is listed in needs approval so I am not following your issue.

You mark things completed by entering a completion date.

I am the advancement chair of my troop and was always able to enter ranks, merit badges, and awards as Complete. Everything would compile in a document and after running that document it would approve all at once. I would print out the Advancement report to go shopping at the scout store and show the employees that my Advancement Sync with BSA national database.

I understand. My problem was that the Advancement report could not be run anymore.

1 Like

@Sandrate_Plate - thanks but I was looking for something like:

I go to scoutbook.com then quick entry, then needs approval report then the needs purchasing report to add items to purchase order, print out needs purchasing, scroll down for advancement report, click on that… that sort of steps notation.

Thanks. We use Troop web host as our main troop tool, so we are not using all functionalities that scout book offers, so I am not familiar with the quick entry option. I was able to find a way to work around, but still not how I used to work.

@Sandrate_Plate - so you are using scoutbook.scouting.org or IA2.0 then. I did ask for the url you were using and your process.

I use https://scoutbook.scouting.org/roster

Sandra

Based on that url, it looks like you are using Internet Advancement 2.0 – not Scoutbook.

So, IA2 really doesn’t record the “Completed” step. IA2 is focused on recording advancement and awards earned (i.e. Approved by leaders). The “Completed” step, as it exists in Scoutbook (as opposed to IA2) is currently contemplated as a way for scouts and parents to indicate that something is ready for Leader Approval. That might mean that a scout got something signed-off by another senior scout or by an adult leader in his or her handbook, but needs a leader to approve it in Scoutbook, or it could indicate that the scout is ready for someone to test him or her, but has not actually completed the requirement (i.e. gotten it signed-off in the handbook).

Marking the item as Approved in IA2 is the equivalent of marking it Leader Approved in Scoutbook. Marking it Awarded in either case means that the item has been presented to the scout. Setting things to Awarded will prevent them from showing up in the Needs Awarding report and (I believe) the purchase orders.

As far as not being able to run the Advancement report, what’s the URL for the report you were trying to run? I may have missed it somewhere in the discussion. If so, I apologize for asking twice. :^)

1 Like

@Sandrate_Plate:
https://help.scoutbook.com/knowledge-base/advancement-report-for-scout-shop-from-internet-advancement-2-0/

1 Like

Yes, thanks. That is how I always work. My problem was that there was nothing to approve anymore, and no report could be printed I got this message:

I approved 49 items and no report could be run. The help link you gave shows the way I worked since the upgrade in Internet advancement a few years ago. This is how I work:

The report could not be run after entering 49 ranks and merit badges.

@Sandrate_Plate - similar to this
Cannot Run Advancement Report

YES!!! I am glad I am not the only one. Sorry more users had to experience the same issue.

1 Like

@Sandrate_Plate Please send an e-mail to Scoutbook Support at:

scoutbook.support@scouting.org

Please include your name, BSA member number, your positions / roles in the unit, unit number, and council name.