Parent stuck on loading scripts page


I have a parent struggling to get training done in my.scouting. He is able to log in, but when he navigates to the dashboard, he can’t get past the “loading scripts” page. Last month, he was able to knock out YPT and some others with no issue. But, in the last 3 or 4 weeks, he started having this issue.

I tried having him do all the things I found on this forum, but now I’m stuck. Anyone else having issue?

1) Hardware: Desktop or Mobile (if mobile, please be specific) desktop windows 10 and Mobile Android

2) Operating system Windows. ANDROID 11

3) Browser Chrome, Chrome Incognito, edge, edge as internet explorer

4) Browser cache has been cleared or you are using a private browsing mode (aka Incognito Window in Chrome) Yes

5) Member ID & Council of person affected124560984 capitol area council

I know that the training system has been up-and-down over the past week or so. When is the last time that the adult tried to take training? The system was somewhat more stable on Friday.

@DavidAnderson06 Please have him try logging in at my.scouting again.

His BSA member ID number was missing / blank there. I have fixed it.

1 Like

For online courses in the BSA learning center would it be better to login via ?


@Bill_W I usually log in at my.scouting first, then go to the training via the my.scouting home page or via My Training.

It’s also usually less complicated than giving new parents or adult leaders another url to remember.

1 Like

No as the LMS feeds training completions back to the official record in my.scouting - thus the reason to log through my.scouting. My.scouting calculates position trained and Y01.

1 Like

Looks like that did the trick. Thanks!

1 Like