Permission Slip Download Button Broken

The Permission Slip download button on our event (5004177) doesn’t work properly. When clicking the button a circle spins within the button, but then when it stops no download is generated. It will generate when I select the box for My Family Only, but I’m trying to run slips for the entire troop (I’m Key 3/Scoutmaster).

@TimothyCooper - you have your role selected in the upper right i gather.

I just tested this for my units and it worked without issue.

How many scouts are invited to the event?

@Stephen_Hornak Role is selected properly to Scoutmaster. Video showing my steps is linked below. Still doesn’t work for me on 7/8/24 8:50 AM EST.
@jacobfetzer Multi-unit event with total of 57 youth invited, but based on the description it should still generate the forms for the unit in which I’m currently actively selected (925 Boys).
Video here: Event Details | Scoutbook Plus and 1 more page - Work - Microsoft​ Edge - 2024-07-08_08-49-11 - TechSmith Screencast - TechSmith Screencast
For what it’s worth, I recorded this on a different PC than I originally encountered the issue.

@TimothyCooper - are you an admin in the other units on the event ?


Yes, for Troop 925 as Key 3 SM, and also Scoutbook Unit Admin for Pack 925 and Troop 927.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.