Photos Not Visible After Uploading to Advancement Note

I have uploaded photos to a scouts advancement page (including verbiage in boxes) but after I save the images they are not viewable. I have tried to do this from my iphone, from computer in both Safari and Chrome. I have reduced the size of the photos and ensured the the photos are jpegs. Help.

1 Like

You have to also save the note (and I think type something) that the photo is within.

I think what you are saying is the photo cannot be opened once saved - that is what I am seeing

1 Like

Thanks for the quick responses.
In response to @jacobfetzer I did save and include text within the note. A thumbnail is present under the note after I save.

In response to @DonovanMcNeil yes, when i click the thumbnail photo, it does not open correctly as an image. A nonviewable item appears with an X.
Screen Shot 2023-08-16 at 10.49.13 AM

1 Like

I am having a similar or the same issue. The last few weeks, every time I upload a picture (with comment) in the rank advancement and/or merit badges, but the picture after I post it will not open. It shows a broken link. I have tried this on my phone and on a laptop. I have cleared my browsing history and tried using in private mode, but it is still happening. I have spent hours trying to post the things I need to post to no avail.

Hi did yours ever get fixed?

My issue described above has not been fixed.

1 Like

Remember that we are all in the same database and web portal so it will be universally broken and universally fixed. Fixes are normally announced in the change log.

It is working for my Scoutmaster and Commitee chair. Is it particular to Advancement Chair?

So it’s being worked on?

It is in the backlog - we do not know If or When BSA IT will work on it

1 Like

You’re all trying to view the same pic, and it works for some but not others?

No, when I upload pictures, it does the thing @JohnCubbison showed in the pictures he added to this I don’t know if others can see the images. I will check that. I was saying other users in my troop are able to post pictures that we can all see.

@DonovanMcNeil @jacobfetzer

I asked my Committee Chair to see if he could view the images under the scout, his reply is as follows:
A couple of the images show up as icons and they don’t expand to full size pictures when I click them. The rest show up as generic picture icons. Almost all of those don’t expand up to anything when I click them. One expands the actual picture of scout handbook page.

Who do I reach out to resolve the issue of my uploaded pictures within notes not being able to be reliably viewed by others?


The developers are aware of the issue. At this time we do not know when it will be scheduled to be fixed. Watch the Scoutbook Change Log for an announcement that is has been resolved.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.