Welcome! This forum has a treasure trove of great info – Scouters helping Scouters! Just a heads up, though - all content, information, and opinions shared on this forum are those of the author, not the BSA.
BOY SCOUTS OF AMERICA

Scouting Forums

Problem printing membership cards

I am a Troop Key3-Delegate and have printed membership cards for our troop in the past, including yesterday, 9/24/20. However, it is not working today, 9/25/20. I am following the same process in my.scouting.org:
Menu > Troop xxx > Member Manager > Roster Details - All > select desired member(s) > Click on membership card image > then I get a Download PDF dialog box and click on Continue. Then I get a new screen that reads:
Authorization failed (-2), and the process stops.
I promise, this worked yesterday. Has something changed?

Hrm…I just tried it and it seems to work for me (I am similarly a K3D). I get the PDF download for all of my adults and youth.

It sounds like it errors out before you get the tabular screen showing the people that you selected, if I can generalize from the operation as I see it.

As a K3D, you should be able to view the Organizational Security Manager at my.scouting. Are you still listed as a K3D in there?

Affirmative. I can still access the Organizational Security Manager screen and am still listed as the K3D. You are correct, I am not getting the tabular screen showing the people I selected, with the Export to PDF option, followed by the warning “You are about to download and preview Print Membership List Report” with a Confirm option. I can only get my own Membership Card form my Profile page… Yesterday I selected 5 members, 3 adults and 2 youth. All worked fine. I’ve re-booted, logged out and in several times, tried a different PC, waited several hours between tries, etc. No luck.

Just a shot in the dark, but have you tried different browsers (e.g. Firefox v Chrome v Edge)?

Good thought! But no work. I mostly use Chrome. Just tried Edge and then Firefox. Same exact result. Wondering of something has gone haywire with my credentials, but I can still do other functions related to K3D.

I had problems in the past with my.scouting, which IIRC required national member support to rebuild my account (or so I was told at the time). I’m not exactly sure what that process would look like .

Maybe try having one of your Key 3 toggle your K3D access off, then save, then back on again to try a reset on the permissions. If that doesn’t work, they might try designating you in the Membership Inquiry functional role and see if that gives you access to print the cards. It seems like there’s something else going on, but it might take a while (and be messy) working it out through your council since direct interaction with member care doesn’t exist for volunteers anymore. It was a bit of a mess when I had to do it some time ago, even with direct communication.

Ok. Will start with request to our CC, who is pretty busy, only partially savvy with this, but usually answers quickly. SM very difficult to get and doesn’t do much technical or admin stuff. Not familiar with Membership Inquiry functional role but will look.

Thanks for your help. It’s definitely not an emergency, but we are having our first in-person meeting in over 6 months on Monday, and after successfully doing the five cards yesterday, thought I’d do the whole troop to hand out on Monday since this is our first meeting since charter renewal processing was completed. Thing is, I did the whole troop yesterday, saved the file and then deleted it - permanently. Because I thought it would be too much trouble to bother with. Then had 2nd thoughts - now I’m determined and also rather annoyed.

OK, that’s interesting. Did one of the Key 3 redesignate you as K3D in the OSM after charter was reprocessed? If not, it was supposed to expire and require redesignation. That might give the support folks a hint as to what’s going on behind the scenes.

1 Like

Yes, this was done after charter renewal in March. We now know it has to be renewed each new charter year. But maybe I’m missing something. What is OSM? What I know is the the K3D credentials went away when the new charter was processed and the CC had to reset them, as he also had to do for the Advancement Chair. I assumed that was just a required routine each year. Any I’ve done several K3D-restricted things since April all along the way, including an occasional membership card print. I still seem to be able to still do whatever else I had been doing. Guess I better check some of the Scoutbook stuff I’ve been doing.

OSM is the Organizational Security Manager at my.scouting. Sorry, I slipped into jargonese. You are correct that the reset is required every year after rechartering. I wasn’t sure when your recharter had hit, and was wondering if it impacted something else.

Scoutbook should be independent of the K3D issue, since generally speaking permissions there rely on positions as defined in Scoutbook, not as defined in my.scouting.

Okay, Charley, you have been so patient and helpful, here’s an update. Stepped away for a couple hours. Had nice relaxing dinner and TV time with wife and finally came back to computer. Decided to try one more time. Still no work, same problem, But I had to look around at other things just for fun. Discovered how to print charter document, for instance. Tried membership card couple more times, and then, Shazam, it started working. Have no idea what I did - nothing different Logged out, back in, just to be sure, and I can get all membership cards I want. No problem. Didn’t change a thing. Must be people named Charley are smart, because one of my sons and grandsons are named Charlie (with ‘ie’). But a good name for smart people! Thanks and have a nice weekend.

And the CC has still not responded to me, so he did nothing either.

Excellent! I’m glad “nothing” worked. I may have to recommend “nothing” the next time someone has an issue. :rofl:

In all seriousness, I’m glad things resolved themselves. It just bugs the little engineer on my shoulder that we don’t know why.

The problem is back today. Yes, it went away late last night and I downloaded membership cards for the entire troop, and saved them permanently this time. But today it’s back like it was yesterday, getting same Authorization failed (-2) message.
could it have something to do with time of day? Or maintenance being performed at HQ? Something not right, for sure.

“Usually” authorization failed messages when trying to run reports in my.scouting (Membership Cards are really just a report) happen when you have been logged in for a while. This issue has been worked on, but still pops up every so often with the reporting server. Logging out and logging back in again should fix this. I say that realizing that from what you said, you tried a different browser, etc.

I think I would have a key 3 or other K3D end the position - and then re-establish it